Problems with VPN blocking programss even if expempt

Joni_1
Joni_1 Posts: 2 Observer

Hey,


I have windos 11 and F-secure total pack with VPN. I have started having problems with the VPN blocking progams even if exempt from protocols. It blocks Spotify, you can't search albums and causes connectivity problems with video games even that they have been exempt from VPN or even that VPN is turned off. Spotify starts working normally when you start it with VPN off.

I am not happy with programm and I am planning to change it after this order period expires, which is sad because I liked that F-secure offers all you need in one place.

Accepted Answers

  • Firmy
    Firmy Posts: 238 Moderator
    edited September 19 Answer ✓

    Hi @Joni_1

    Welcome to the F-Secure Community page. Thank you for your post.

    May I know on which device you have this issue?

    If the issue is on your Android device, this is most likely due to the power save settings on the device.

    Please check the following settings on your device:

    Settings -> Apps -> Freedome -> Battery -> Optimise battery usage -> All (apps) -> Freedome, should be unselected i.e. "don't optimise" (if already set as don't optimise, enable and then disable again the optimisation in case that'd make it effective)

    If that doesn't help, there's more:

    Settings -> Apps -> Freedome -> Mobile data -> Allow background data usage, and Alllow data usage while Data saver is on

    Settings -> Battery and device care -> Battery -> Power saving mode, Background usage limits

    Settings -> Battery and device care -> Battery -> More battery settings -> Adaptive battery

    Settings -> Battery and device care -> three dots in upper right corner -> Automation -> Adaptive power saving

    Connections -> Data usage -> Data saver

    This discussion might be related to your issue. You can check this link also https://community.f-secure.com/en/discussion/124823/with-freedome-on-audio-apps-keep-stopping

    Kindly let me know if this helps.

    Thank you and stay safe.

    AmirulJaims
  • Firmy
    Firmy Posts: 238 Moderator
    Answer ✓

    Hi @Joni_1

    I just received an update from the FREEDOME team, they can reproduce the issue with "FREEDOME turns on protection automatically when it starts" and "Spotify added to VPN bypass app".

    We suggest you:

    a. Kindly remove Spotify from the VPN bypass app.

    OR

    b. If the issue remains after doing this, kindly turn off "FREEDOME turns on protection automatically when it starts" and manually connect FREEDOME after your PC has started.

    Kindly let me know if you have tried this. Looking forward to your reply.

    Thank you and stay safe.

Answers

  • Joni_1
    Joni_1 Posts: 2 Observer

    As per my first post I am using windows 11 on PC.

    As stated in my post, I try to re-describe the problem using example. As I start my computer and automaticly run freedome before any application. Then if I open Spotify, it does seems to function properly, untill you search for new songs, that it finds, but It wont start playing untill I turn of freedome VPN.

  • Firmy
    Firmy Posts: 238 Moderator

    Hi @Joni_1

    Thank you for your reply.

    We are checking with our FREEDOME team and we will get back to you once we have received more information.

    Thank you and stay safe.

  • Firmy
    Firmy Posts: 238 Moderator

    Hi @Joni_1

    Kindly add your network as trusted network on your PC.

    Follow these steps to set a network as trusted:

    1. Open F-Secure FREEDOME user interface
    2. Turn OFF the VPN protection 
    3. Go to Settings
    4. Enable Automatic killswitch
    5. Click Allow connections to other devices in trusted networks
    6. Select the network used in Trusted networks dialog
    7. Click Save 

    Kindly let me know if this helps.

    Thank you and stay safe.

    Jaims
Product & Pricing Info