F-Secure SAFE 2 minutes shutdown sometimes since 18.2 update

laszlo3
laszlo3 Posts: 8 New Member
edited August 3 in F-Secure SAFE

Hello,

I've got 3 computers in my household. 2 windows 10 PC, 1 windows 8 PC. They are different hardware wise, the only thing is the same on the three computers is that all of them has f-secure safe installed on it. First I realized this problem on one of the Windows 10 PC. Sometimes the shutdown was exactly 2 minutes, instead of the few seconds.

Sadly (or luckily) it is not every shutdown, but bugged me so I tried various things with no luck. Even reinstalled the windows 10 from scratch, but that didn't help. Sometimes later both of the Windows 10 PC produced this bug, so I thought this was a Microsoft bug, till last night. Because last night I shutdown my Windows 8 PC, and guess what, I also got the 2 minute shutdown bug there. After booting up the machine I saw that F-Secure updated to 18.2 that day, so it is must be it.

I found out there are more people with this bug, for example here: https://malwaretips.com/threads/f-secure-18-2-released.111240/page-2

Please fix this, thanks.

Tagged:
Ukko

Accepted Answers

  • Jaims
    Jaims Posts: 860 Former F-Secure Employee
    Answer ✓

    Hi @laszlo3 @Websquid83

    While our R&D team are still looking to resolve this issue, can you try disabling the Tamper Protection in the settings as a temporary workaround and let us know if that helps with the shutdown delay.

    To disable Tamper Protection;

    • Launch the F-Secure SAFE UI
    • Click on Viruses & Threats
    • Click on Settings
    • Click on Edit Settings on the left
    • Turn off Tamper Protection below

Answers

  • Jaims
    Jaims Posts: 860 Former F-Secure Employee

    Hi @laszlo3

    Thanks for reaching out to us.

    While we embark on the task to reproduce this issue, I would like to ask if you have set any Scheduled Scanning on these affected machines? Perhaps this could be the first guess.

    By the way, I presume the Windows 8 (you're referring to here) is actually a Windows 8.1 because Windows 8 isn't supported on our platform.

    We will revert once we have an explanation for this root cause or contact you if we need to acquire a diagnostic log to aid this investigation.

    Thank you.

  • laszlo3
    laszlo3 Posts: 8 New Member

    Thanks for the reply. No schedule scanning is set, and Windows 8 is Windows 8.1, yes.

  • Websquid83
    Websquid83 Posts: 6 Observer

    I have the same problem under windows 11. At first i thought it was related to another program, but it must be f-secure safe 18.2.. The shutdown is sometimes delayed by up to 4 minutes, previously it was a matter of seconds.

    Ukko
  • Jaims
    Jaims Posts: 860 Former F-Secure Employee

    Hi @laszlo3 @Websquid83

    Our team have now received some diagnostic log files and are now into this.

    While the investigate on this long shutdown is ongoing, we kindly ask for your patience and we will update you again as the development unravel.

    Thanks for your patience and understanding.

    UkkoBill_K
  • laszlo3
    laszlo3 Posts: 8 New Member

    I appreciate your help with this, Jaims.

  • Bill_K
    Bill_K Posts: 5 Observer

    I'm not the original poster but have been experiencing the same shutdown delay running F-Secure SAFE under Windows 11 which began after the upgrade to v18.2 . When I saw someone posted on the MalwareTips forum that the delay was eliminated when they turned Tamper Protection off I tried it and found that shutdown time returned to normal. I turned it back on and the delay returned, and then back off and there was no delay again. Hope that helps you determine the cause of the problem to come up with a solution. Thanks for your kind support to resolve this issue.

  • laszlo3
    laszlo3 Posts: 8 New Member
  • Jaims
    Jaims Posts: 860 Former F-Secure Employee

    Hi @laszlo3

    Yes, it is safe to temporarily turn of Tamper Protection.

    Tamper Protection was recently added to F-Secure SAFE 18.2 to prevent anyone from terminating F-Secure services or processes and modifying F-Secure registry or files. Windows Security is capable of notifying you if by any means SAFE is turned off. Therefore, the primary security protection is still in use even without Tamper Protection on.

    Our R&D are work still investigating this issue and that we hope to release a fix soon.

    Bill_K
  • Websquid83
    Websquid83 Posts: 6 Observer

    Hi @Jaims ,

    thank you very much for your reply. I´ll be at home tomorrow and will surely check if that will help with the delay.

    I´ll let you know...


    Kind regards

  • Websquid83
    Websquid83 Posts: 6 Observer
    I´ve tried it serveral times now and the problem persists even after I´ve switched off tamper protevtion. It might be a little bit faster now, but it´s not solved. 
    
    FreezeDuck
  • geo551
    geo551 Posts: 2 Observer

    On a Windows 11 desktop, I also had shutdown times of around 2 minutes with version 18.2. After deactivating the tamper protection, the shutdown time was reduced to around 7 seconds (checked several times). So I can confirm that this workaround improves the situation significantly 😀.

    Bill_KUkko
  • Bill_K
    Bill_K Posts: 5 Observer

    My testing is consistent with @geo551 as posted above and has been repeated to confirm.

    Ukko
  • FreezeDuck
    FreezeDuck Posts: 1 New Member

    Turn OFF Tamper protection do not help. Problem still the same but very random.

    Ukko
  • laszlo3
    laszlo3 Posts: 8 New Member

    For me turning off tampering protection worked. All my computers are shutting down normally for the last three days.

    Bill_K
  • take04
    take04 Posts: 10 Explorer

    The delay is random even on my computer. It is not always delayed, but the shutdown time is arbitrarily slow. I thought there was a relationship between cache and temporary files.

    Because the delay is random, the tamper-proof setting remains the default.

    Ukko
  • Bill_K
    Bill_K Posts: 5 Observer

    Just saw the following post about the shutdown delay on the MalwareTips thread and thought it might be helpful here in determining the problem and hopefully a solution (posted by user "tipo"):

    "Feedback: Turned tamper protection off and the pc started and shut down properly. But this happened to me only on win 11 pro. On win 10 pro never had any issues with f-secure. Odd, odd, odd!!"

  • Bill_K
    Bill_K Posts: 5 Observer

    Hi @Jaims,

    Hoping to receive an update on the status of this issue and its potential fix.

    Thanks for your kind support,

    • Bill
  • Jaims
    Jaims Posts: 860 Former F-Secure Employee

    Hi @Bill_K

    I can confirm that we are making some significant progress on this issue but the release has not yet been finalized yet.

    Be rest assured that you will be notified once this fixed has been pushed to production.

    Ukko
  • grenbo
    grenbo Posts: 1 New Member

    Hi James,

    I use win10 and have not had problems with 18.2 until now. My computer started behaving strangely, at first Firefox stopped working. Then my tabs froze and I had trouble shutting down Firefox.

    I restarted the machine but the problem continued, and then the font on my desktop began to get bigger or smaller if I rolled the mouse wheel. I followed the advice in here and turned off tampering protection and then all the problems disappeared. This is not reported here.

  • Bill_K
    Bill_K Posts: 5 Observer

    I've had that update installed for several days and it seems to have resolved the delay for me. Thanks!

    geo551take04Ukko
  • geo551
    geo551 Posts: 2 Observer

    I also can confirm the observation of Bill_K. The shutdown time on the Win11 PC is still low (few secs) even after the temper protection was re-enabled. The recently released patch seems to have fixed the problem.

    Thank you!

    Bill_Ktake04Ukko
  • laszlo3
    laszlo3 Posts: 8 New Member

    I meant to click the original reply for accepted answer, not mine, sorry.

This discussion has been closed.
Pricing & Product Info