Not sure whether F-Secure Internet Security is working or not

RamheshBabu
RamheshBabu Posts: 2 New Member

Hello

For the past two day's i am noticing this pop up message when ever i visit any banking site. Not sure whether my F-Secure is working or not. Need help to understand this issue and help me to resolve it. You can refer enclosed attachment


Accepted Answer

  • RamheshBabu
    RamheshBabu Posts: 2 New Member
    Accepted Answer

    Thank you for the update.

    I had contacted Support Team through Chat and got my issue resolved. I tried to connect with Support Team for Chat message but couldn't able to start the discussion i tried to registered myself even then chat option didn't worked out. Don't know why Chat option was not available for the two days

    Hence i had posted my issue in Forum, Came to know that Remote Access task was running and it was closed now my issue is resolved.

    Once again i would like to say "Thank you" for the help and details shared

Answers

  • Ukko
    Ukko Posts: 3,242 Superuser

    Hello,

    In general, you could try to reach their Official Support Channels. For example, web-chat. Contact support | F-Secure

    F-Secure Support Agents are certified to provide assistance, including remote support, and can directly analyze additional logs (generated with the F-Secure Support Tool). And check if anything is suspicious or a false detection.

     Not sure whether my F-Secure is working or not.

    Well, F-Secure Internet Security is basically with many modules and parts. So, at least, you could check some of them.

    Browsing protection:

    Additionally and "AV" (third-party, but generally reliable and safe services / tools):

    For the past two day's i am noticing this pop up message when ever i visit any banking site.

    Screenshot is about recently introduced tweak for F-Secure Banking Protection. It should 'disable' some remote access tools.

    There is description: Remote Access Blocker | SAFE | Latest | F-Secure User Guides

    For the initial release it marked as:

    When a banking session starts, Banking protection detects and blocks remote access to your computer and displays a warning. This prevents phone scammers from leveraging remote access software to perform online thefts.

    The feature is limited to Anydesk and TeamViewer, but more applications are to be added later this year.

    So, perhaps, F-Secure detected an active remote access connection to your device. And immediately disrupts the connection after Banking Session started.

    If you did not use any kind of related tools. So, better to reach their support for further analysis.

    If do - then, maybe there is a quite normal situation. As double check you can try to open "Windows Events" journal and try to find any related entries about.

    Also, maybe visited banking website with a somewhat tricky design and there is a 'false positive' notification. Can you check with any other banking website. For example, https://nordea.no - is this notification still appeared?

    Thanks!

    Jaims