with F-secure Freedom on I cant log in to Facebook

Francke
Francke Posts: 4 New Member
edited February 23 in F-Secure FREEDOME

Strange thing but,

windows 10, Crome or Firefox, Facebook, 2 different laptops, Lenovo and HP, Freedom and e.g. Sweden. All is updated.

Cleared cockies and all that, restarted.....


If I have Freedom on and try to login to Facebook it will just ask me, in an endless loop, about my mail and password and no time to fill in that before the same question occure.

If I close freedom and try to login, everything goes normal. Then I can set back freedom to on.

Same thing on both my laptops, both crome/Firefox and it just Facebook, nothing else what I can see.


I have solved it by turn Freedom off and on but it seems wrong way to go.

Accepted Answer

  • Jaims
    Jaims Posts: 827 Community Manager
    Answer ✓

    Hi @martink @Francke

    We were was able to reproduce this issue with several of our Finnish Gateway (GW) instances by :

    1) Connect Freedome

    2) Open Firefox private browsing window and browse to facebook.com

    3) Try to accept cookies consent -> it is shown again and again

    Problem occurs with most of Freedome's European GWs except Czech Republic, Poland and France GWs. The following workaround seems to work:

    1) Open facebook.com page before connecting VPN and accept cookies consent

    2) Connect VPN

    3) Login to facebook.com

    Similar problems have been occurring for VPNs in general:

    https://www.reddit.com/r/firefox/comments/o902jw/facebook_keeps_refreshing_login_page_after/

Answers

  • Jaims
    Jaims Posts: 827 Community Manager

    Hi @Francke

    I could not reproduce this issue using the mentioned browsers, server and on a Windows 10 PC.

    Please confirm that you have the latest F-Secure Freedome version 2.42.736.0 running, if not, kindly update or reinstall Freedome VPN. Also try to turn On VPN by connecting to another FREEDOME location.

    If the problem persists, turn Off VPN and try the steps below:

    Change the VPN protocol in use:

    1. Open F-Secure FREEDOME 
    2. Go to Settings
    3. Click Choose VPN protocol
    4. Switch between OpenVPN and IKEv2
    5. Turn the VPN protection on 

    Check:

    • Restart computer
    • Restart your network router
    • Try to connect with another internet connection entirely (share for example with mobile hotspot)
    • Make sure Windows is updated

    Run the following command line commands:

    • ipconfig /flushdns
    • netsh winsock reset
    • netsh int ipv6 reset

    After performing the above steps, try to turn the protection on and test again.

  • Francke
    Francke Posts: 4 New Member

    Hi, Thanks for the response but sorry, that didnt work.

    Did it all, got a video, 3 Mb, how it looks. You want it ?


    Both my pc's are new installed, updated etc etc.

    One is brand new, Lenovo, and onother an old HP Pavilion, new installed.

    everything are updated.

  • Jaims
    Jaims Posts: 827 Community Manager

    Hi @Francke

    If all the above instructions failed, we will need to investigate further and the Freedome log from that device is required to carry out this investigation.

    Kindly contact our support so we could assist you remotely, and further get the logs if the issue persists.

  • martink
    martink Posts: 412 Adventurer

    I had the same problem, see the end of

    https://community.f-secure.com/en/discussion/124169/freedome-blocks-net-for-s-mobile-2-10-0#latest

    It went away for a short while, but now it has been back for some time when I use Brave in a private window and portable Firefox in a private window.

    I simply turn Firefox before log in to Facebook and the n back on after logged in.

  • Francke
    Francke Posts: 4 New Member

    Ok, thats a workarond and its the same for other browser. I can live with the workaround, it just seems odd

This discussion has been closed.
Product & Pricing Info