No notification when blocking

RoberGeenPaniekRoberGeenPaniek Posts: 6
edited June 30 in F-Secure SAFE

This has annoyed me very much!

While developing in Visual Studio, UWP applications would not start up. Even right from creation, without any real involvement from me.

Error message was "Unable to activate Windows Store app ... activation request failed ... Access is denied' This could mean a lot of things.

In the event viewer: "Unable to start DCOM Server ...". Which is like 'What ARE you talking about? DCOM?'

After a lot, and repeated, web searching I found a remark about F-secure, which led me to blocked applications (created and installed fully internally by myself!), and the ability to unblock. This has cost me DAYS.

In some cases there was reference to "Suspicious:W32/Malware!DeepGuard". I tend to switch that off.

The problem is that in such case F-Secure does not give a clear notification of what is going on, it is all happening in the BACKGROUND.

So, for F's sake: DISPLAY a notification!

Answers

  • VilleVille Posts: 485

    Hi,

    The product should always show a notification when blocking anything. It is using Windows toasts (on Windows 10 that I assume you're using). Please make sure you have not disabled toasts from Windows side for our product. (Windows settings: Notifications and actions, scroll down for the list of apps that are allowed to show)

    As for the detection, DeepGuard considers applications that have never been seen before as suspicious. This is great for normal users, but for software developers, every time you recompile the app, it will be seen as brand new and therefore suspicious. This can be a bit annoying and you could consider excluding the target folder in your development environment from scanning (product main UI, tools, app and file control, excluded, add new) .

    Ville

    (F-Secure R&D)

    UkkoDawidFSJaims
Sign In or Register to comment.