Submitting a sample does not work

Hello,

I want to submit a sample but when I go in F-Secure Safe tools and try to click on "submit a sample", the page cannot be found 🤔 https://www.f-secure.com/en/web/labs_global/inform-us

Is it an issue ?


Best Answers

  • Kimmo13Kimmo13 Posts: 27
    Accepted Answer

    Hello,

    I just checked the "submit samples" tab in the GUI and I was directed to this page:https://www.f-secure.com/en/business/support-and-downloads/submit-a-sample 😉


    Ukko
  • SethuSethu Posts: 613 Moderator
    Accepted Answer

    Hi @Kimmo13

    I hope that it’s likely you’ve already noticed a pretty big change that our website and URL changed recently and there were some URL's not changed/updated as soon as the issue is fixed by our backend team. We can confirm the issue is fixed now as our SAFE for Windows products use for the "submit sample" functionality working as expected.

    Jaims

Answers

  • UkkoUkko Posts: 2,972 Superuser

    Hello,

    I am only an F-Secure user.

    Yes, it is likely broken redirect or 'changed' destination for F-Secure SAS page. You can to use next one URL:

    This one should be opened from main user interface "Tools" tab at the end.

    Maybe it will be fixed later (on F-Secure servers/website). Sounds that their website is under redesign/restructuration/optimization. So, some URLs can be outdated / broken or legacy ones.

    Thanks!

    Kimmo13
  • Kimmo13Kimmo13 Posts: 27

    Hello Ukko,

    Thanks for your help.

    I'm not sure but it seems that your link is for business users and not for home users ?!


    Ukko
  • UkkoUkko Posts: 2,972 Superuser

    Hello,

    I am also not sure. But, yes, the page is in the business section of their website.  And that also confuses me a bit.

    However, there are some points about it:

    • I did use it some days ago (despite the fact that it is located there). And I received response / result;
    • this is not the first time when Submit A Sample from Tools tab does not open the desired page. When I drew attention to this last time, the "fix" was a redirect to this mentioned URL (or maybe not exact this one, but it was also located under business section and looks as current one);
    • if to choose ""I want to give more details about this sample and to be notified of the analysis results"", required forms with inclusion of Home Solutions (as 'Affected product'). So, perhaps it is designed for Home users too.

    Sorry for delay with my reply!

    Thanks.

    Kimmo13
  • Kimmo13Kimmo13 Posts: 27

    Hello,

    Thanks Ukko for your answer/solution. I try and it is OK.

    However I hope that this tools tab issue will be definitively fixed in the near future. Did you contact the support about it ?

  • UkkoUkko Posts: 2,972 Superuser

    Hello,

    Actually, I did not contact support about current state. And my previous experiences were about beta program (so, I contacted F-Secure via beta channel. But not now yet).

    But just because situation is not pinned to beta or to stable only - maybe to contact Support is most suitable step. Sounds that it is solely based on server configuration for this resource (that, maybe, should still be with redirect to correct current URL):

    When I first time encountered this situation - I thought it is maybe pinned to software hardcoded (something) or just legacy destination after restructuration. But I am already not sure what is definitely wrong and what should be fixed or changed.

    Kimmo13
Sign In or Register to comment.