No access to Search in iTunesStore

Hello,

the next problem: I can not use the search funtion in the Apple iTunes Store - no results on my iOS devices, also no results on my Mac.

The Gateway Germany brings no results (no access to the iTS), but e.g. Ireland sends the results.

I use the newest versions of Freddome on MacOS and iOS.

My impresson is that there are more and more problems with the this German Gateway.

What is happening? How top fix this problem?

Thanks

Claus

«1

Comments

  • JaimsJaims Posts: 398 Moderator

    Hi @hanswurst 

     

    I just tested with the German server and it worked fine on an iPhone as well as other servers. Is Germany server the only gateway with this issue?

     

    Looked this up on Apple support page and it seems to be a known issue that get fixed on its own. You may want to try some steps given here and also try connecting to another network and see if that works since issue persists on Mac too. 

    Sethu
  • Yes, e.g. ireland and the Netherlnds works fine.

  • I tried few more gateways, and the German one it the only one which does not like to used with Freedome.

    well, I wait for the following MacOS/iOS and guess everthing will be get better ;-).

    BTW: Is Freedome compatilbe with the next MacOS/iOS? 

  • JaimsJaims Posts: 398 Moderator

    May I know if you still face this issue on both the iPhone and Mac devices?

     

    If yes, then I suggest you try to reset the DNS cache for both devices and try installing Freedome VPN if the DNS reset fails.

     

    Click here to see steps for Mac and below for iPhone steps.

     

    iPhone: Pull up bottom menu and press on Airplane Mode button, wait 5-10 seconds and then press again to disable it.

     

    Test again and let us know if that helps.

    Lakshhanswurst
  • Hello,

    I did this, but no changes. I also restarted all devices, no changes. 

    I spoke to the support of Apple but they said it must be a problem of Freedome.

    But probably in a few weeks the problem disappeared with the new MacOS/iOS and no iTunes anymore.

    Claus 

  • JaimsJaims Posts: 398 Moderator

    Hu @hanswurst 

     

    What happens if you turn off FREEDOME and then try to perform the search? You may want to try it on mobile data or while connected to another network.

     

    May I also recommend a reinstallation of FREEDOME on those affected devices and see if that works? Test again before reinstalling FREEDOME and let's see if the issue persist while FREEDOME is completely taken off the iPhone/Mac.

  • Turning OFF results in the page with the found items.

    Turning ON (German gateway) results still in a error message, no matter if iOS or MacOS (all newest versions).

    No matter if WLAN or mobile data.

    Like before.

    I use Freedome from Iceland and I use the German iTunes Store, and the poblem appears ONLY with the German gateway.

  • I have had the same experience under iOS. No search possible in Apple Music and the Apple Podcast App. 
    If I switch Freedome OFF it works. 

    hanswurst
  • JaimsJaims Posts: 398 Moderator

    Hi @hanswurst 

     

    Have you updated to the latest iOS 13.1 version and check if this issue still persists in the German server? Please test on a different network like mobile data or another wifi connection so we could narrow down the cause while we raise this issue with our backend team.

     

    @lbauerochse Are you facing the same issue with German server or all the servers? What iOS version are you running on your iPhone? Have you tried to reset the DNS cache using the steps provided above?

     

    Appreciate your patience while we investigate this issue even further.

  • Hi,

    and thanks for replying so quickly. Yes, it is (only?) the German server. After changing to Belgium I had no problems, neither in Apple Music, Podcast nor iTunes. Same if I switch off Freedome, everything works fine.

    I am running Freedome on an iPhone 8 with iOS 13.1

    And yes, I have tried to reset DNS as described (Flightmodus) and even restarted the iPhone after shutting down all apps completely. The problem persisted.

     

    Best greetings

    Lothar

  • Hihi,

    happens with mobile data and wifi on iPhone 8 Plus and iPad Pro 2018. All devices have the newest OS. Also on my MacBook Pro (2016), newest MacOS.

    Maybe we can find the problem here: I live in Iceland, use Freedome to acces the German gateway. I use the German iTS - this combination (Iceland -> German gateway -> German iTS) does not work.

    Using the e.g. the Belgium gateway  works fine.

    It happens, like another user mentioend, also in the Poscast app (iPhone).

    Remember: The problem affects only the page after starting a search for an item/band in iTS.

    Greetings, Claus

  • JaimsJaims Posts: 398 Moderator

    Hi @hanswurst@lbauerochse 

     

    We are still unable to reproduce this issue either. Search works nicely whenever we use the German location. We have IP addresses in Germany in multiple networks, tried all those networks and no problems whatsoever with any of them.

     

    Can you check what IP address you have from us (for example with https://www.whatismyipaddress.com) when you encounter the problem with iTunes.

  • Hi, my IP-Adress is:

    IPv4: XXX.XXXXX

    IPv6: Not detected

    I just checked before I looked up my IP-Adress: When choosing Belgium/Brussels as location in Freedome I had no problem with the search-site in Apple-Music. After changing to Germany/Falkenstein I geht the reply: "Leider ist ein Problem aufgetreten. Erneut vesuchen" = Unfortunately there is a problem. Try again.

     

    Greetings. Lothar

     

    Edit: PII

    hanswurst
  • Hello,

    see PM.

    Greetings,

    Claus

  • JaimsJaims Posts: 398 Moderator

    Hi @lbauerochse@hanswurst 

     

    Thank you for your messages.

     

    Your responses have helped us to reproduce the issue, so we are investigating the root cause and we will revert once there is a new development. 

    Lakshhanswurstlbauerochse
  • Thank you for the feedback - and further research into this problem. Maybe it is a problem caused by Apple?!

    Please let me know if you need further details.

    Claus

  • I installed Catalina and the problem still persists.

  • Hello Jaims,
    any news about fixing this bug?
    Thank you,
    Claus
  • JaimsJaims Posts: 398 Moderator

    Hi @hanswurst 

     

    It appears we are having issues with the German server. Just like this post here, it seems we can’t solve this issue at the moment.

     

    Apple has clearly blocked some of our German IPs with their iTunes search for an unknown reason. We are still in contact with them but it is quite unlikely this will change at least in the nearest future.  

  • Maybe you should change the Gateway or offer more than only one. More and more I get problem using this one. E.g. using Google end in a error message - something like that this IP address (or range) is blocked because too many users use it, don`t remember. But it happenend several times now. Also the problem with the iTS (which also affects iTS from other countires).

    Please fix this problem!

  • For some time using Google search I get more and more the message that I can not use the search because too many users use this IP (or similar, I dont remember). I should try it again later. Also the Apple iTunes Store does not work correct with the German (and others) gateway.

    It gets more frustration to usw Freedome as I have to turn it OFF or change the location more and more.

    Please fix this problem e.g. by offering further gateways. Thank you.

  • JaimsJaims Posts: 398 Moderator

    Hi @hanswurst 

     

    Thanks for your feedback and suggestions.

     

    We are unable to reproduce this issue on other servers than Germany. I can suggest you reinstall Freedome on the affected devices and test again and if the issue persists, we may have to email you to get some details for further investigation.

  • hanswursthanswurst Posts: 57

    The problem still exists. Also with the newest versions (darkblue).

    Very nnoying the problem.

  • hanswursthanswurst Posts: 57

    @lbauerochse has the same problems.

  • Yes, the problem still persists. So bad. If it doesn't get fixed soon I will change to another VPN-Client. 

    hanswurst
  • hanswursthanswurst Posts: 57

    I agree with @lbauerochse.

     

    The problems persist also with iOS, with the iPad - and of course on the Mac - I am very annoyed.

     

    Problems also come up with the German gateway in general - Google does not like and blocks sometimes, also booking flight tickets from Icelandair ALWAYS shows me a security page to confirm that I am a human and not a robot. Freedome OFF is ok for booking via Icelandair.

     

    Maybe you should change the Germany gateway and choose a more serious one. Even Apple dislikes it. You should mention this in the description for Freedome.

     

    Sorry, but I do not have the feeling that something is happening. Also the problem with receiving E-Mails still persists. I receive answers from the support F-Secure with the info "We check it" and "We work on it" and blablabla - but in the end nothing is happening. I just have to pay for a new subscription ...

     

    :-(

    lbauerochse
  • hanswursthanswurst Posts: 57
    ... I just have to pay for a new subscription which is now just a little bit darker - but with the same bugs.
  • hanswursthanswurst Posts: 57

    Bildschirmfoto 2020-01-31 um 14.59.38.pngI wanted to open a youtube video but I got this message. German Gateway.

    Please offer a different one!

  • JaimsJaims Posts: 398 Moderator

    Hi @hanswurst @lbauerochse 

     

    This case is still ongoing with Apple and we are yet to get a final resolution from them. We sincerely apologize that this is taking long, we will update here once we find a solution with them. 

     

    About the new dark blue theme, yes we have just released the new theme colour, so you might see this once you update your F-Secure products. This is one visible change you might notice for now.

     

    About the German nords, we were able to reproducte some of the issue with some videos, but most of the youtube videos worked without any restriction. It may be that the video uploader/record company/other rights owner or a copyright agency has not allowed this particular video to be shown in Germany. This kind of blocking is very common on Youtube, some estimates say that even 3-10% of the youtube videos are not available in Germany.

  • hanswursthanswurst Posts: 57

    Hello @Jaims. Well, the text says something like that lots of traffic comes from this network (IP address?). It depends not on which video I want to see (like what you guess). It is about the IP address. This gateway/this provider is used a lot and from other VPNs, users, ...

    Not the first time I see this message, it poped also by a normal search in Google.

    Thats why I recommend to offer another gateway/node (?) in Germany.

This discussion has been closed.