Safe and banking protection with Firefox 64 bits

Hello,

 

I wonder if the problem of no bank protection on Mozilla Firefox (67.0, 64 bits) is not related to the fact that the F-Secure extension was enabled. Because F-Secure is only in 32 bits.

 

Since the reinstallation of F-Secure, I have not reactivated the extension for Firefox, and bank protection works.

 

Just an assumption on my part.

 

Sincerely,

JYV

Best Answer

  • SethuSethu Posts: 547
    Accepted Answer

    Hello @jyvaut58 

     

    F-secure Safe browsing protection does support both 32 bit and 64 bit versions. You can also see here the supported browsers for F-secure  Safe. Please refer this KB article and this KB article to know more about browsing protection.

Sign In or Register to comment.