FS Protection PC 17.7 releases

FengpingFengping Posts: 50 F-Secure Employee

Release 17.7 beta 1 (4.20.936):

New features:

  • New settings dialog combines AV and common settings. You can open the settings dialog from all the same locations as before. You can always view settings without elevation but to change them you need to elevate. Help is missing for this release and will be added in the future releases.
  • Logout added to main UI. This will log you out from your current account and expire the client. You need to login again to use it. This is intended for use cases where you want to switch to a different account. There are black triangles in the Logout dialogs which is known issue and will be fixed in the next release.
  • Restart prompt now has dropdown to select when to remind again.

Fixed issues:

  • LOC: localized "Privacy" word with small mistake ("About" window). (SAFE_BUG-02726, PBL-4998)
  • Network installer didn't resume after sidegrade reboot (PBL-4959)
  • Title is truncated in network installer (PBL-4913)
  • SafeSearch not enabled when Parental Control enabled (PBL-4912)
  • Family rules guide poor translations (PBL-4671)
  • fsdiag does not collect the MSI log files properly (PBL-4660)
  • Help: Differences between 'wording' (term) under Help and under User Interface on current day. (SAFE_BUG-02640, PBL-4417)


  • SimonSimon Posts: 2,653 Superuser

    Love the new Settings UI, but it's still all very 'white'.  What are the chances of a dark theme?

  • VilleVille Posts: 515 F-Secure Employee

    @Simon we have discussed the dark theme internally, but it looks like it would be quite expensive and not that requested feature so far. So chances are very low.



    (F-Secure R&D)


  • SimonSimon Posts: 2,653 Superuser

    That's a shame, but thanks Ville.

  • Version 17.7 beta 1

    Have installed this version and it appears to be working fine however it wont allow me to login etc. Despite me following the installation link/with one time password etc;my account states my license has expired.

    FS Protection is registered in windows security center and everything else checks out fine. What do I do?

  • Lord_AmiLord_Ami Posts: 68

    Smooth upgrade. But I really do not like (user is Administrator) clicking on the top button to enable editing of settings.


    Can settings' UI be run as admin by default?


  • VilleVille Posts: 515 F-Secure Employee

    @williams001 did you follow the insructions at beta.f-secure.com when joining this program? Also, be aware that if you change your email address in beta.f-secure.com, the fs protection e-mail account will not change, it will be the one that you had when you joined the program. If you did follow the instructions, then there is a bug somewhere, please create a bug report in beta.f-secure.com


    @Lord_Ami the settings opens this way so that any user can always see the settings, even if they do not have administrator permissions. Also for users with admin accounts, if you take security seriously, then admin account is separate from your main account and you have to enter credentials every time you elevate, which is quite annoying if you would like to just check settings. We are happy the way it works now and not planning to change it.



    (F-Secure R&D)


  • jazzmusicjazzmusic Posts: 2

    One feature that can be added is that when usb is inserted, it will automatically detect whether it needs to be scanned. My English is not good, use google to translate...

  • SimonSimon Posts: 2,653 Superuser

    @jazzmusic wrote:

    One feature that can be added is that when usb is inserted, it will automatically detect whether it needs to be scanned. My English is not good, use google to translate...

    F-Secure would detect and block any malicious activity from a USB stick if it should try to activate, therefore, in my opinion, it's not necessary to automatically scan every USB stick when inserted, as this would take some time for, say, a large capacity stick containing just photos . 

  • martinkmartink Posts: 396 Adventurer

    Smooth upgrade as always.

    The user is only notified when windows gives the message turn av on.

    Otherwise do not see anything.

  • yeoldfartyeoldfart Posts: 512 Superuser

    same here

  • Lord_AmiLord_Ami Posts: 68

    Here too. The beta overall has been really stable and has caused no issues for me.

    I'd call it RC if it was up to me Smiley Very Happy

  • FengpingFengping Posts: 50 F-Secure Employee

    Release 17.7 beta 3 (4.20.1675):

    Fixed issues:

    • About failed to open (PBL-5177)
    • Close button reboots machine from sidegrade something went wrong page (PBL-5161)
    • Wrong translation of the "Unlock settings" link text to Russian (PBL-5147)
    • fsdiag does not wipe the content of the previous page of wizard (win 7) (PBL-5145)
    • Check for Updates can indirectly result in malfunctioning UI (PBL-5138)
    • Attempting to scan a file with shell extension crashes Explorer (PBL-5133)
    • Help is not available for Scan Wizard. (SAFE_BUG-02763, PBL-5129)
    • F-Secure Browsing protection Extension for Chrome blocking Drop down menu on Google analytics site (PBL-5126)
    • [LOC: fi] Incomplete translation (PBL-5119)
    • Link underline too far in settings (PBL-5111)
    • LOC: Title of settings switched to ProductName (SAFE_BUG-02756, PBL-5110)
    • Turning on protection fails after system hoster restart (PBL-5109)
    • Browsing Protection isn´t working (SAFE_BUG-02753, PBL-5104)
    • Ransomware protection appears disabled (TA: CompSec UI tests 5018/01, 09, 10 fail) (PBL-5101)
    • Protecting user not show with non-admin user in first time installation (PBL-5100)
    • Double clicking to "enter subscription" dialog leads to for ever loop of "no internet, please try again" (PBL-5094)
    • Missing Installer title on Red network installer (PBL-5093)
    • Strange focus rectangles in settings (PBL-5092)
    • Recent events buttons missing spacing (PBL-5091)
    • Logout or Log out (PBL-5088)
    • Help is not working in red builds (PBL-5082)
    • Logout missing product name from dialog title (PBL-5072)
    • Settings missing product name from dialog title (PBL-5071)
    • Logout flow adjustment (PBL-5069)
    • OLS 2.223 incompatible with CS13 (PBL-5067)
    • Settings UI can be opened if all security features are turned off (PBL-5062)
    • Time Limits still working(warning flyer) after Log out and expired (PBL-5055)
    • [LOC]Logout dialogs localizations (PBL-5052)
    • [LOC] Installer new EULT and PRIVACY links (PBL-5049)
    • After elevation and clicking Logout twice 2 pop-ups are shown (PBL-5046)
    • Logout dialog is too small, likely some of the localization wont fit in (PBL-5040)
    • SAFE's banking protection not dropping the banner for a certain customers (PBL-5030)
    • Network installer thinks it's in secure temp if content in resume parameters (PBL-4962)
    • Forbid to write non-numbers to the Port field (PBL-4893)
  • SimonSimon Posts: 2,653 Superuser

    Gosh, I don't think I've experienced any of those bugs!

  • FengpingFengping Posts: 50 F-Secure Employee

    Release 17.7 beta 4 (4.20.1985):

    Fixed issues:

    • Text truncations on the Tools tab (PBL-5220)
    • Wrong translation of the "Suspended" word to Russian (PBL-5219)
    • Too wide Proxy fields in the Settings window (SAFE_BUG-02787, PBL-5207)
    • When border dots are misleading a bit (addition to SAFE_BUG-02783). (SAFE_BUG-02784, PBL-5204)
    • Strange focus rectangle on buttons (SAFE_BUG-02783, PBL-5203)
    • Cosmetinc issues when buttons being hovered upon (SAFE_BUG-02777, PBL-5183)
    • Text truncation on "Delete all events from list" confirmation window (SAFE_BUG-02776, PBL-5182)
    • Help is not available for Family Rules (SAFE_BUG-02775, PBL-5176)
    • "Advanced network protection" term changed to "Web traffic scanning" (PBL-5166)
    • Large amount of Internet Explorer crashes (PBL-5164)
    • Some Chinese translations fixes (PBL-5155)
    • Product may report malfunction in slow computers (PBL-5134)
    • Slightly unclear explanation for "Updates" tab of Settings (SAFE_BUG-02764, PBL-5131)
    • End User License Terms text truncation in the installation windows in some languages (PBL-5105)
    • Installation may not continue automatically after the restart (PBL-5097)
    • "Turn on" form Windows Action Center does not do anything when user has logged of from the SAFE account (PBL-5074)
    • Unable to log out from the SAFE account when the subscription has expired (PBL-5044)
  • Lord_AmiLord_Ami Posts: 68

    Smooth upgrade. As always Smiley Very Happy

  • martinkmartink Posts: 396 Adventurer

    Yes, only the emails from this thread indicate that there was an update.

  • UkkoUkko Posts: 3,198 Superuser
    •Large amount of Internet Explorer crashes (PBL-5164)

    Before beta3(?) - I experienced a lot of "freezes / stucks" (crashes) with Internet Explorer 11.

    Just because there was some else changes (or certain circumstance) - I did not connect situations with fs protection. Then, I found that extension / addon with implemented fix for some uncommon trouble. Thus, I understood (and found) that BP extension is updated for Internet Explorer 11 to some of 2.2* builds (this one that was reverted back previously).


    Soon after (and, probably, for beta3) BP extension is switched back to 2.197 build. So, noted "freezes / stucks" (crashes) are gone.

    But today, with beta4, I found that something wrong with Internet Explorer 11 and Browsing Protection extension. HTTPS support is incomplete. Blockpages (?! all or some) for HTTPS are not visible. Search ratings are not there. Although, maybe I hit certain state. But all was OK before and I do not remeber such hits...

    Extension / addon is enabled. Features are "ON". But sounds as "HTTPS support" are not there.

    I do able to suspect that situation is appeared only after upgrade to beta4 (or even next system launch).


    // later added: The Reason is enabled EPM option.

    With disabled EPM (mode) - BP functionality for HTTPS support with OK state.

    I did not create report via beta-portal since of this (although, today I do able, at least, to get login page under safe instance; but Support ticket with unclear response yet).



  • yeoldfartyeoldfart Posts: 512 Superuser

    I run IE beta Version (Official build) dev (64-bit) and do not encounter such problems, it is just a statement I make since IE has a Chromium kernel.

  • UkkoUkko Posts: 3,198 Superuser

    @yeoldfart wrote:

    I run IE beta Version (Official build) dev (64-bit) and do not encounter such problems, it is just a statement I make since IE has a Chromium kernel.



    Sounds that it is Microsoft Edge. At least, if Internet Explorer is not completely rebranded (declined) to fresh Microsoft Edge (Chromium-oriented) with upcoming builds.


    My current Windows 10 (1903) still with two different browsers: Internet Explorer 11 and Microsoft Edge (44*?).

    In fact, with both browsers - F-Secure BP HTTPS support is not available on current time. With Microsoft Edge by default, with Internet Explorer by enabled EPM option.


    I did not try "fresh" Microsoft Edge (beta) yet. Maybe, there are improvements - but I still think that for HTTPS Support need to install F-Secure BP extension (otherwise - noted functionality is not available). Perhaps, beta Microsoft Edge with support for Google Chrome extensions by default (and as a result - proper state for HTTPS Support functionality of F-Secure BP).




  • yeoldfartyeoldfart Posts: 512 Superuser
    you are right it's edge
  • yeoldfartyeoldfart Posts: 512 Superuser

    for your further info I simply got it from there https://chrome.google.com/webstore/detail/browsing-protection and it works like a charm.

  • UkkoUkko Posts: 3,198 Superuser

    Sounds that URL is redacted (as a result "Page not found"). But, yes, it is known place for "Google Chrome" addon (fs protection Settings tab "Browsing Protection" with this information).

    I, usually, used it for browsers like Opera.

  • FengpingFengping Posts: 50 F-Secure Employee

    Release 17.7 beta 5 (4.20.2816):


    Known issues:

    • The About page is missing some localization strings, should be fixed in the coming release

    Fixed issues:

    • Values on the Support tab are not visible on some languages if narrow (PBL-5321)
    • Main UI browser extension "Set up now" link to help broken (PBL-5310)
    • Scheduled scan for "each month" launched each week (SAFE_BUG-02791, PBL-5306)
    • A setting can be changed without administrator rights – misleading "Edit settings" explanation (PBL-5303)
    • The blank Account ID is shown if subscription code is not entered yet (PBL-5297)
    • Cannot paste characters in Proxy setting field (SAFE_BUG-02787, PBL-5293)
    • The Subscription valid date is still showing after the expiration (PBL-5281)
    • Subscription valid date 1.1.1970 if the subscription code was not entered yet (PBL-5279)
    • Wrong subscription valid until date if no expiration date (PBL-5273)
    • The Proxy Address value does not take effect properly (PBL-5262)
    • New help button has ugly focus rectangle (PBL-5261)
    • Hover effect on selected settings tab not working (PBL-5257)
    • LOC: "Support" string is not localized yet. (SAFE_BUG-02786, PBL-5243)
    • Small alignment issues with "shield" icon in Settings (PBL-5239)
    • Small alignment issues with toggle switch in Settings (PBL-5238)
    • Unnecessarily alarming scheduled scan result for PUA in scanning report (PBL-5231)
    • "Subscription is about to expire" window is shown after the expiration, log out and restart (PBL-5215)
    • "You are not yet protected" is not showing after log out if expired (PBL-5213)
    • Some focus issues in Settings (PBL-5202)
    • Web pages of "illegal" category should be blcoked by default (PBL-5201)
    • SAFE 17.6 continuously reports malfunction (PBL-5134)
    • Misleading name for DeepGuard detections counter (PBL-5113)
    • New Settings UI, time control does not support 12-hour clock (PBL-4957)
  • FengpingFengping Posts: 50 F-Secure Employee

    Release 17.7 beta 6 (4.20.3102):

    Fixed issues:

    • "Check for updates" from system tray does not trigger update (PBL-5363)
    • Scheduled scan start time hours field does not allow one digit numbers (PBL-5334)
    • Usability problem with scheduled scanning control hours field (PBL-5332)
    • Settings Window crashes when you change scheduled scan time (PBL-5327)
    • SAPC 17.6 - SAFE on SAFE reinstall flow is broken (PBL-5326)
    • User Port value vanishes if you edit the address (PBL-5325)
    • Help button shows "help not available" page (PBL-5319)
    • Unnecessarily alarming scheduled scan result for PUA (PBL-5231)
    • Log out SAFE account improvement (PBL-5173)
    • SAFE 17.6 continuously reports malfunction (PBL-5134)
    • Misleading title for DeepGuard detections counter (PBL-5113)
    • Missing Information for Protection Logout Window (PBL-5068)
  • FengpingFengping Posts: 50 F-Secure Employee

    Release 17.7 beta 7 (4.20.3453):

    Fixed issues:

    • Inaccurate AM/PM value location on the Scheduled scanning area (PBL-5421)
    • Banking protection session does not start with https://www.poste.it/ (PBL-5418)
    • Parental Control is not currently working as expected (PBL-5391)
    • Log out confirmation dialog has wrong, non-customized icon (PBL-5383)
    • Banking Protection doesn't trigger consistently for https://bank.smile.co.uk/ (PBL-5371)
    • Ing.de and Paypal.de in Chrome, when it comes to Banking Protection (PBL-5370)
    • Check for updates from system tray does not trigger update (PBL-5363)
    • The Support Tool instruction in Help does not match with the actual UI (PBL-5260)
    • Scan Option "Every four weeks" is not described in Help (PBL-5259)
    • The Help button is located differently on different Settings tabs (PBL-5254)
    • Change the Help page which opens from the Notifications tab with F1 (PBL-5140)
    • Disable the "Full screen maximize" button for the Logout pop-up (PBL-5045)
  • FengpingFengping Posts: 50 F-Secure Employee

    Release 17.7 beta 8 (4.20.3560):

    Fixed issues:

    • .NET missing dialog text is truncated (PBL-5333)

    • Ransomware protection doesn't work (PBL-5426)

  • martinkmartink Posts: 396 Adventurer

    Please, educate me: How can a basic user tell if Ransomware pårotection is working or is not working?

  • VilleVille Posts: 515 F-Secure Employee

    Hi @martink 


    It's not easy to test if it's working or not, since the algorithm that triggers it is quite complicated, so I can't give you any good advice on that. We accidentally broke it in beta 7 and didn't notice it immediately, but our automated tests flagged it.



    (F-Secure R&D)


  • martinkmartink Posts: 396 Adventurer

    Thanks, I guess you would need a special sandboxed  environment and a piece of ransomware which the basic user would not have.

This discussion has been closed.