Connection not working reliably (Windows 10) since a few weeks

I am using Freedome for a long time on various devices (Windows 10, Android, iOS).


Since a few weeks, both Windows 10 machines show issues: After a random time (most often a few minutes), no traffic is going through anymore, although the UI still shows "Connected".


Reconnecting to the same server or to a different one typically solves for a few minutes.


I have found the advice in some article on this site to do "netcfg -d" and restart the computer. That hasn't solved my issue.


What can I do to get rid of this annoying behavior?


Freedome version is 2.22.5580.0





  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Hello mz686034534,


    This needs further investigation from our support team. Please get in touch with them via chat or phone here along with the Freedome logs to investigate this futher.


  • NarrSD
    NarrSD Posts: 24

    Greetings -- 


    This may or not have to do with another problem that recent Windows 10 releases are known to have. 


    I've seen no trouble with dropouts on Freedome, but it will appear to have dropped out without  saying it's lost its connection if the Win10 operating system drops out, at least in this particular way:


    - the problem is actually in some interaction Windows has recently added with wifi drivers 

  • NarrSD
    NarrSD Posts: 24

    Greetings -- 


    This may or not have to do with another problem that recent Windows 10 releases are known to have. 


    I've seen no trouble with dropouts on Freedome, but it will appear to have dropped out without  saying it's lost its connection if the Win10 operating system drops out, at least in a particular way:


    Before considering this, it would be well to assure Freedome isn't the problem, which you can do by disabling it in the usual way from its top panel, to Off. Then run for enough hours to have had the problem and then some -- if you don't, then Freedome is implicated, and you should (and in any case) proceed with their conversation with you, and not try this  scheme.


    If you want to consider the scheme, if Freedome is not the problem, a description is here, with 

     definite caveat.


    As it explains, I think I'd only try this if your problem is with wifi, and if you also have a wired connection and cable solidly available. Plus knowledgeable help, if any doubt...because if the fix doesn't work, otherwise you're going to be without use of your  PC on the internet for a while...


    - the problem is apparently in some interaction Windows has recently added with wifi drivers -- at least that's where I and others have found it. Perhaps/probably non-wifi internet connections as well.

    - Microsoft has  waltzed around this for months, and there is an enormous amount of try-this out there, much of it involving temporary disabling connections, resetting them, or most effective  for another hour or three, rebooting the PC.

    - what seems to help stalwarts who find the idea is to roll back to an earlier version of the driver in use, in my case, the wifi driver. You can find those under Network adapters, in the Device Manager control panel.

    - newer drivers I believe seldom work, at least those supplied by Microsoft. There is an ability to Roll Back from the current driver on the tabs for the one you want, but this didn't help me or others, perhaps because of having tried other downloaded updates before. 

    - thus I used the categoric Windows driver fix: you can also use the button to Uninstall Driver, after which reboot the PC.  Then Windows will load 'a driver' to recover the use of the hardware. I'm a little cloudy as to why this automatic re-installation works when you've apparently disconnected the internet as in my wifi -- either because Windows comes stuffed with default drivers, or because it hived away separately the original driver on the machine. 

    - I don't see anyone else complaining about this 'remove' driver procedure, but do understand it could have risks. If you're doing it  on the wifi driver, which is where I believe this fault happens, then you could connect to the wired port if you need to, should Windows need actually to  download a replacement driver.

    - In the end, I got an old driver, but by date and version clearly not the original supplied for the machine, more recent than that, two years earlier than the earlier updated 'best' driver which wasn't too new either. I therefore have the feeling that Microsoft knows this problem exists if they don't fix it yet, and may give you a driver they know is safer when in this procedure. Not necessarily true, if an idea Smiley Wink


    Hope useful to hear about, in any case, and I've put the thought to try to take Freedome out of the equation before thinking to try this where it belongs, front of this  message.

  • Thanks NarrSD for your detailed information.


    So far F-Secure support was reactive (sort of) but couldn't provide a solution yet.

    The problem is shwoing on two machines, one laptop used with a Wifi connection and a desktop being wired. The desktop was more stable the last days, but has shown the issue a couple times still.


    I have not seen the issue when Freedome was switched off (which I am getting more used to now to be able to use the Laptop at all :-( ). Maybe not trying long enough.


    Will try both your suggestions, using for a long time w/o Freedome and potentially setting back drivers.


    Also still waiting for F-Secure to analyze log files and hopefully finding something helpful.



  • Although... Isn't setting back drivers what I did with "netcfg -d" already? Think so.

  • NarrSD
    NarrSD Posts: 24

    replying to both:

    - your plan sounds good to try the long time w/o  Freedom

    - that the desktop on LAN has same problem may well mitigate against the forced-replace driver procedure

    - also, as noted, I have some unanswered concern whether/how a machine  with only the single connection you'd disturb would recover itself. It would require the postulated hidden backup driver if Microsoft actually does this; or alternatively, you'd have to download the proper driver for the machine's card(likely to be problematic), bring it across on a USB chip etc., and then manually install. So...!


    Best fortune, and it's sounding you'll need Freedome to troubleshoot the actual problem.

  • Short interim status...


    I had sent F-Secure the logs captured by Freedome as requested. Did not hear back if they found anything useful, but maybe they did, because meanwhile a new version came out and they pointed me to it.


    And, since that that version 2.23.5653.0 is installed, Freedome hasn't stopped working yet. The past days I haven't used the machines much, so I will resist early hurrays. But maybe they have fixed it.


    Will have a close eye for the next couple of days.



  • NarrSD
    NarrSD Posts: 24

    Wishing  you good fortune on the fix.


    I have another issue in for analysis. but this has to do only with DNS, on certain Chinese sites which should be open.


    On your problem, I haven't seen wifi dropouts since de-upgrading the Windows wifi driver -- looks very good.


    Prior to this, some of the online 'fixes' helped a bit, but really only rebooting the machine cleared the problem -- for a few hours. If it's useful to know.


    Again, glad you're clear of this now apparently. It's pretty annoyiing, no?  Smiley Wink

This discussion has been closed.
Product & Pricing Info