Reproducible issue with iCloud Photos

Dear all,


I have noticed that my macOS machines using 2.20.5548.0 with a US East Coast endpoint are unable to upload photos to iCloud Photo Library. This is a strange problem, but one I can reliably reproduce across the board (multiple networks, multiple machines). Here are the details:


1. This does not affect the iOS client, even with the same US East Coast endpoint

2. It affects no other service, including photo sharing notifications and other iCloud services

3. This is not an application or iCloud issue: other devices synchronise the same content at the same time


My guess is that one of Freedome's endpoints has been blacklisted by Apple or their CDN provider. Would your network team care to investigate?



  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Hi Tarsier,


    Did this issue start to occur with the recent version of Freedome? Was this issue present before as well?

  • Hi Laksh,


    This issue only occurs with Freedome and seems to have cropped up recently. Unfortunately, I cannot tell you exactly when it started, as I do not look at my iCloud Photos on a regular basis on my Macs. As the issue does not occur on iOS, it never occurred to me to investigate.


    I had a look at other threads on the forum related to this issue, and my symptoms match exactly: whenever Freedome is on, iCloud Photo Syncing just stops dead, as if the network were off, without any error message, and it resumes the minute I turn Freedome off. No other iCloud services are affected.


    Judging by the volume and date of the reports, this issue has been known for some time. Has the network team looked into it at all?

  • Do you have any luck when you disable the automatic killswitch in Freedome's settings? This looks to have fixed my AirDrop problems but I might've spoken too soon when I replied to my thread and said it fixed iCloud Photos.

  • Hello, @saltinewolf! Thank you for chiming in! 😊


    Alas, the automatic killswitch feature has caused us so much trouble that we keep it disabled permanently. I tried toggling it, just in case, as you kindly suggest, but it appears this feature has no bearing on the ongoing iCloud issues… ☁️


    If, as posters speculate in other threads on the forum, the issue is network-based and not client-based — an assumption which makes complete sense to me — it makes sense for it to be intermittent: depending on what endpoint you happen to hit and what other users are doing on it at the same time, Apple and/or their CDN providers may or may not block you. 🙅‍♂️


    @Laksh, could you provide us with an update? 💬

  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Hi Tarsier,


    I would recommend getting in touch with our support team here via chat or phone so that this can be taken further for investigation.


  • Just to chime in, I also have this exact problem. It's annoying to have to disable Freedome every time I want to get my photos synced.
  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Hello Everyone,


    After some investigation on the iCloud issue, it turns out to be an issue in Mac OS and this is not possible to be worked around. There is a bug report about this with Apple. 


    Mac OS syncs photos only when the computer is connected to Wi-Fi or via network cable. However, when VPN is connected, Mac OS checks the wrong network interface for network connectivity and refuses to sync.

  • This problem seemed to start with High Sierra. Do you know if anyone has given it a look on the upcoming Mojave?

This discussion has been closed.

📢F-Secure Quiz Challenge📢

Join our online quiz session on June 15th, 2023, at 11:00 AM EEST and stand a chance to win prizes.

Product & Pricing Info