F secure Internet Security Installation Failed

I was given a F secure Internet Security when Buying my new laptop free . But when I tried to install it again and again says Installation Failed. Please Help.It wasted my data about 1 GB up to now since each time the installer downloads 50% and installation fails. some times it's progress bar go up to 99% and fails and sometimes it fails when 55% 60 % etc... I've 3 year license but no use. I'm on Windows 8.1 pro Genuine. And I just reinstalled windows. But it fails like before.

Comments

  • SimonSimon Posts: 2,608 Superuser

    Try running the Uninstallation Tool, reboot your computer, then reinstall.  The problem is probably because the installation failed the first time, and it has left some remnants behind.

     

    Installations can also fail due to debris from other previously removed security software being left on the machine.  If you have recently uninstalled any other security products, I suggest you also use their Uninstallation tool to clean up before reinstalling F-Secure.

     

    F-Secure may not install or run correctly if any other security software is present on the machine.

     

    F-Secure Uninstallation Tool

     

    Other Uninstallation Tools

    Ukko
  • Lucky16Lucky16 Posts: 4

    I re installed windows 8.1 as a fresh os. (Formatted). Then tried. But it failed at 99%

  • SimonSimon Posts: 2,608 Superuser

    Just a thought, but maybe there were Windows updates still missing when you tried to first install F-Secure?

     

    Using the uninstall tool, then rebooting, then re-installing, usually works in these situations.

    Ukko
  • Lucky16Lucky16 Posts: 4

    Thanks.I'll try again check and if there's updates pending, installing updates and install again. But any other ideas? 

    Is this happened to only me...

    Ukko
  • SimonSimon Posts: 2,608 Superuser
    No, it happens to lots of people, as you will see from other posts on the forum. And I don't think it just happens with F-Secure. Security suites bury themselves deep within the system, and it is often the case that something trips up the installation.
  • Lucky16Lucky16 Posts: 4

    Isn't there any offline installer so I can try installing again and again without data wasting...

  • SimonSimon Posts: 2,608 Superuser

    I forgot to mention, it might be an idea to disable Windows Defender before installing F-Secure. F-Secure will try to disable WD during the installation, but occasionally this causes issues.

     

    No, I don't believe there is an offline installer.

  • UkkoUkko Posts: 2,995 Superuser

    Hello,

     

    Sorry for my reply. I'm also only F-Secure user (their home solutions).

     

    With my own feelings: such output is something unexpected. For example, to write/access to certain folder is permitted. Or even 'network connection' is dropped. Or own F-Secure integrity checks about downloaded/unpacked files.

     

    Just because your experience is 'fresh OS installation' - maybe not a pending Updates - but not all of them under system can be a reason for stuck.

     

    For example, such knowledge base article:

    https://community.f-secure.com/t5/F-Secure-SAFE/How-do-I-install-F-Secure-SAFE/ta-p/78187

    with advice (before installing F-Secure solution) like to be sure that "Windows is up to date" and some further generic things.

     

    Thanks!

This discussion has been closed.