F-Secure Freedome does not launch at all.

F-Secure Freedome does not launch at all.

If I run on the command line, I got error:

--------

~$ /Applications/Freedome.app/Contents/MacOS/Freedome

Assertion failed: (APPLICATION_PATH.length() > 0), function initialize, file /Users/mbbldr/jenkins/workspace/clp-client-desktop-mac/common/settingsmanager.cpp, line 292.

Abort trap: 6

--------

 

OS: macOS High Sierra 10.13.1

Answers

  • LakshLaksh Posts: 4,424

    Hi yoshiokatsuneo,

     

    Did you happen to see this error all of a sudden? Or was it after an upgrade?

     

    Have you tried to uninstall and reinstall Freedome on this Mac?

     

  • I just re-installed the latest version, and the issue happens.

    (I'm not sure how to uninstall. So, I just re-installed.)

    I'm not sure when it happens. In the past(some months ago), there was no problem.

     

  • chris_chris_ Posts: 12

    I have similar issues after today's update.

     

    After disconnecting, Freedome often doesn't work any more. I can either reinstall to start a VPN connection again, or I have to force quit 4 VPN processes from Activity monitor (which is more bothersome since I have to enter my credentials 4 times).

     

    Did you guys change some stuff? I also see a user now named _fsvpn and a process called FSVpn Analytics Service. I disabled analytics in app and unchecked the service option during installation. What exactly is this?

     

    Screen Shot 2018-02-02 at 5.25.26 PM.png

  • chris_chris_ Posts: 12

    After spending some more involuntary time with this, it seems that Freedome is broken at the moment.

     

    I use the latest version on Mac (2.14.5108.0) and will try to revert to an older version via Backups.

     

    Here is a video of what happens after a disconnect or me trying to switch a server:

     

    Video Preview via Google

  • To Y.

    I try to understand error text in first mail.
    - file is settingsmanager.cpp, there is something on line 292
    - and there is text: abort trap 6, whatever does it mean?
    - is it possible in Mac to use command type?
    - to find out, what is on line 292
    - error affects on desptop, perhaps?

    My thoughts
    Näsäviisas
  • I just run the command, and error message is from F-Seucre Freedome product. 

  • LakshLaksh Posts: 4,424

    Hello yoshiokatsuneo and chris_,

     

    Kindly get in touch with our support team via chat or phone as mentioned here in order to further troubleshoot on this issue.

  • There was no response on the chat at all.

     

     

  • chris_chris_ Posts: 12

    @Laksh

     

    Chat has been unavailable so far.

     

    Could you please send me a link to an install .pkg (Mac) for an older version (from maybe 3-4 weeks ago)?

    Like mentioned and shown in my video, I can't disconnect or switch servers without much hassle right now and restoring an older version from backup didn't work.

     

     

  • chris_chris_ Posts: 12

    Ok so, I got this resolved via Chat.

     

    Reinstalling alone didn't help, I had to delete Freedome completely and reinstall, which fixed it.

  • LakshLaksh Posts: 4,424

    Appreciate the update, chris_.

    Glad to know the issue is now resolved.

This discussion has been closed.