Cannot connect to Internet with Freedome off.

My issue:

At some point I noticed that when I turned Freedome off, I can no longer connect to the internet or when I get a connection for a while, it is very very very slow and only some websites open an others do not. I've tried Mozilla, Chrome and Internet explorer. Same behaviour. Feels like back in the day when I had a modem..

 

I have Windows 10 with all the latest updates and latest version of Freedome as well. I'm not sure when the problem started, since I've kept Freedome on as default. The problem got annoying when I noticed some performance degrading when playing online games with Freedome on. 

 

The PC I have has two network adapters. I connect via a cable modem to the Internet. I have a lan cable connected to one of the network adapters. Network speed is about 80mbps normally.  

 

What I've tried:

- Turning freedome off

- Shutting down freedome

- Turning off the autostart in Freedome

- Uninstalling Freedome

- Reinstalling Freedome

- Disabling the network adapter not in use

- Disabling the Freedome TAP Adapter

- Uninstalling network adapters and letting windows reinstall them

- ipconfig / release, renew, release all, renew all, flushdns

- netsh winsock reset

- netsh int ip reset

 

 

I've gone through the forums here and the problem has been seen before:

https://community.f-secure.com/t5/F-Secure/Cannot-connect-PC-with-Freedome/m-p/68898#M1187

https://community.f-secure.com/t5/F-Secure/Cannot-connect-to-internet-with/td-p/92113

 

The solution in the past seems to have been to wait for new version of Freedome. 

 

 

Zeno

Answers

  • LakshLaksh Posts: 4,428

    Hi Chompy,

     

    Please contact our support team via chat or phone as seen here in order to troubleshoot further.

     

This discussion has been closed.