FREEDOME VPN terminates after asking for account elevation This topic explains what to do if FREEDOME VPN terminates after having asked for account elevation.
Symptoms
When you install or upgrade FREEDOME VPN, you are asked to elevate your user account and enter the administrator password as FREEDOME VPN requires administrator rights for the configuration. Instead, FREEDOME VPN fails to complete the configuration and terminates itself.
Diagnosis
You may have manually removed your "root" account from the /etc/sudoers
file on your Mac, which means you do not have sufficient access rights to allow FREEDOME VPN to gain root access for the configuration.
Solution
To solve this problem, add "root" back to your /etc/sudoers
file before you start installing or upgrading FREEDOME VPN. After FREEDOME VPN has been installed and you have successfully connected to a virtual location, you may once again remove "root" from the /etc/sudoer
file if you want to. Subsequent virtual location changes will not require root level access.
Note: Your next FREEDOME VPN upgrade will again require "root" in the /etc/sudoers
file.