Release 109 install chore

Superuser

Release 109 install chore

I'd like to read your feedback, my statement is again that update (upgrade ?) needs 2 reboots to be fully isntalled, I really don't understand why: is it be design ? does it simply suck ? I need as a beta tester to be informed on that, it would spare a bug report...

 

1 ACCEPTED SOLUTION

Accepted Solutions
Superuser

Re: Release 109 install chore

Hopefully they will get back to you soon, but it could simply be what Ville mentioned earlier, and therefore something which will be addressed in future releases.

View solution in original post

15 REPLIES 15
Superuser

Re: Release 109 install chore

It shouldn't, at least none of the others have for some time now. Did you upgrade from the prompt? I haven't got around to switching my computer on yet, but will let you know how it goes when I do. :)

In the meantime, the beta team welcome any feedback from any experience, so if you have a moment, it would be good if you could pop over to the beta site and leave your comments.
Superuser

Re: Release 109 install chore

Hello,

 

After created..... I thought.. that maybe I just wrong understand situation;

Maybe you mean... that just it's stuck and not started update/upgrade.

If it's mean that just update-process not started without restart system - it's can be or more "not hard" explanation, or meaning that was troubles during start process (if you start update, but that freezing);

 

But what operation system you have?

 

Possibly with some of "modern" (like Windows 8, for example; probably Windows 7 same situation too) most of "popular" installers/updates (and etc. processes) by companies..... not required any restart/reboot systems.

 

Probably (and possibly it's totally like that) - current version of F-Secure release also must be with that behavior - without any required for restart/reboot system, but:

 

 - maybe it's can be something new - like new service/new module/new plugin or something close to that - which maybe..... require a reboot system.

 

  - maybe some troubles in launched processes - like if it was opened browser or something another, which "paused" upgrade.... and restart-require for "full access";

 

---------------

 

But if you have, for example, Windows XP or Vista....  probably here still required restart/reboot for any "installations" - and probably it's must be just one time...

 

---------------

 

Also it's just if all will be normally during upgrade.

Maybe space on drive ...... maybe another troubles..... maybe "conflicted" software (during new update - it's can be rechecking for that points).

 

Anyway - what certainly and when it was required for "two reboots"? Probably it's must be just after "installation"/downloaded process.

 

But anyway - most part of protection software time to time.... take long time for upgrade and it's better give a time for system... without any other actions.... just for download/upgrade/install - steps. How you wrote previously about BullGuard - previously it was same with F-Secure..... just because also one antivirus-core, which not really optimisation for fast work (that just my opinion), but BullGuard also have good firewall-core (which originally also have troubles with updates/upgrades) - and.... probably it's can to give more troubles during update/upgrade, than with F-Secure.

 

But.... how I know BullGuard 2014 already with a lot of improved in that steps too. Just because all of that....

 

 

If you meet more than one require for reboot - it's mean something wrong. You can create a report.

But.... maybe reasons for restart/reboot was logical.

Superuser

Re: Release 109 install chore

thank you for the replies, I have W 8.1 x64, I filed a bug report on that with a screen capture attached which shows that most of the updated processes have been dowloaded but are not installed. I find it hard to admit an udpdate needs several reboots to get everything up and running.

It's not a critic, only an observation as a beta tester.

By the way I was one of the beta testers for Bullguard IS 2014: never seen this, I can't say more due to NDA.

Bye

Superuser

Re: Release 109 install chore

Hi YOF,

 

Just to answer a couple of your points:

 

The updated components can take a few minutes to all be installed.  Sometimes a reboot can seem to speed this process along, but I've always just let it do its own thing, and they do all eventually get installed.  I've just upgraded, and am currently awaiting the Aquarius update to be installed, but I can hear my hard drive busily working as I type.

 

With regards reboots, the upgrade prompt did state that a reboot may be required (my highlight):

 

Untitled-1.png

 

Admittedly, it didn't say how many restarts may be required - in my case, it was none, but I always reboot after an upgrade anyway, as a matter of course.

 

I think everyone's machines respond slightly differently, according to what other software they may have, so maybe that would account for your multiple reboots.  If you submitted an FSDIAG with your bug report, the beta guys will be able to see what went on, and I'm sure they will come back to you in due course.  :)

 

Just checked again, and my Aquarius has now updated - around 3 minutes after the upgrade process finished, and without rebooting as yet.

Superuser

Re: Release 109 install chore

Maybe you also mean situation:

 

 - List of updates have new modules/upgrades with status "not installed";

 

And F-Secure do not alerted about that by prompt about "comes new update - install that now";

 

 

It's probably normal behavior: if updates ready for installation (start installation) during launch system - it's must be with prompt from first minutes. If "start of installation" will be available during work with system - it's can be "freezing" for prevent any troubles for user.

 

Here you, of course, can start installation of updates by kick with restart system (same with launch system during "updates ready/prepare for installation" - downloaded not enough time to time) or by "check now" in settings about "Updates/Global settings";

 

It's mean - can be situation with "downloaded new updates", "status not installed" and can be hours without prompt about "comes new update - install that" by F-Secure. It's probably using by some other companies too.

 

 - And that probably better, than situation.. when you work with system - comes update... and require restart without any questions.... or during installation something goes wrong and system broken - of course with "information", which not saved during that.

 

But probably anyway..... how it with F-Secure updates - can be without prompt/alert a lot of hours, but usually must take less... than hour. Also, of course, any "check now for updates", "awake from sleep mode" and etc - give that prompt from first seconds.

 

 

 - About BullGuard I wrote... just because here was some troubles during installation (not like - need two restart or comes updates, but not installed). Simply really troubles with update - when something broken... something not wrong...  and user must create various steps for fix that. But BullGuard in that situation was just explanation like "good company" (where it's not always - just time to time).

F-Secure

Re: Release 109 install chore

@yeoldfart 

 

Packages getting downloaded before upgrade into "Not installed" status was documented in the release notes of TP108 and expected behaviour. This is due to changes in the upgrade logic. When the product is ready to do the upgrade, it will prompt with a dialog and "Upgrade" button, which requires elevation.

 

The new upgrade logic should be fully working by the time of TP110 (= no more early downloads).

 

Ville

(F-Secure R&D)

 

Superuser

Re: Release 109 install chore

@Ville 

just to mention I didn't dl the upgrade and installed it prematuredly as I did for rls 108, I launched it only when I got the propmpt on my windows desk.

Thinking of the average enduser, imo this should not happen in order not to make him "uncomfortable" .

Superuser

Re: Release 109 install chore

@ Simon

hi !

it's the propmpt I launched the procedure on, but it didn't take a few minutes and a restart it stretched over much more times and reboots...

 

btw how can paste a screen capture here ?

Superuser

Re: Release 109 install chore

To post an image, click the Insert/edit image button in the reply pane, then you can upload the image from your computer.

 

It does sound like your upgrade experience wasn't as smooth as it could have been - did you submit a report via the beta site?