I can't get freedome to work


I can't get freedome to work

So, I bought Freedome total 5 days ago online. It worked very well for 3 days, then it kinda died. Everything was normal in the morning, but when I came home during the evening, freedome didn't seem to connect to any virtual location. It just said "connecting..." for like a half an hour. So then I deleted the app from my laptop and my phone, logged in again, but it would not let me anymore. Everytime I tried to log in, it always said that I don't have any licenses left anymore and that I had to release one I don't need anymore. I released one and it let me log in and name a new device and everything seemed working just fine, BUT after the last page that says "Congrats! You are now using Freedome to the fullest!" I pressed "ok" and my phone threw me to the front page of Freedome; it looked like I didn't do anything at all. It was still the free version of freedome, only with the app security. I have repeated this many times now, and every time Freedome says “Congrats!” but after I press “ok”, it’s still the same free version. App does not work on my phone nor on my laptop. What’s wrong?
Community Manager

Re: I can't get freedome to work

Hi Murkki,


When you go to the Subscriptions page in Freedome, do you see it as trial?


Are there only 2 devices in which you have Freedome - which is your laptop and mobile?

Has somebody helped you? Say thanks by giving likes. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.