Connection fails when switching networks


Connection fails when switching networks

Everytime I change wifis, for example when coming home from work or vice versa, freedome fails to connect. It tries for a while and then just turns off with a message "something went wrong" and tells me to send a diagnostics file via email. This has been happening for a few weeks now and it's really annoying, especially because if I don't remember to relaunch freedome it just leaves the connection unprotected. I have the killswitch turned off because leaving that on prevented my time machine back ups for some reason.


Using OS Sierra 10.12.6 and Freedome 2.20.5548.0 


Where exactly do I send that file? Please fix this asap.







Re: Connection fails when switching networks

I might also add the issues that in addition to time machine back ups, killswitch also kills airdrop and that your chat support never seems to be available. 

Former F-Secure Employee

Re: Connection fails when switching networks



Welcome to F-Secure Community!

Have you tried to uninstall and reinstall Freedome and see if the issue persist ?


Have you tried to change locations and see if it helps?


Could you also check this KB article to set up the port configuration for Freedome on IOS?


Thank you