Can't run Freedome because of OpenGl 2.0

Senior Member

Can't run Freedome because of OpenGl 2.0

Hi,

I wanted to use Freedome for an older MSI Netbook with Windows 7 Starter 32 Bit and an Intel 3150 Onboard Graphics Chipset.After the installation when I tried to start the program an error pop up appears where it tells me that I need Open GL 2.0.I checked that and found out that the Intel 3150 Graphics Chipset doesn't support that version.

 

The driver is on the latest version.Is there any other solution for me to get Freedome running on that Netbook?

6 REPLIES 6
Superuser

Re: Can't run Freedome because of OpenGl 2.0

Hello,

 

Sorry for my reply.

 

There available next Knowledge-base article:

https://community.f-secure.com/t5/F-Secure/Freedome-shows-an-error-message/ta-p/82543

 

And next topic where also noted "intel 3150 graphics chipset" (under one of replies):

https://community.f-secure.com/t5/F-Secure/opengl-2-0-error-message-on/m-p/82438

 

Where (as under Knowledgebase-article) some tips to contact support (because they have or had 'workaround'). If previously there was available "Support-ticker by mail" - on current time just Chat/Phone (and I not sure if it can be useful in such situation; also even it can be not available at weekends);

 

Maybe tomorrow (?!) with workdays there will be proper response from F-Secure Freedome Team or from F-Secure Community Team. If not - I will suggest just re-up topic (or directly contact Community Managers);

 

Spoiler
Not sure about 'workaround from Support and its view" (I can to suspect that they should be with specific modified installer ?! if there missing any other workarounds) - but as temporary workaround - most likely some of previous builds (before certain update) should work under your system/machine (but it outdated builds.. and most likely not an option at all) - just if there possible that under your system 'stay' some of previous installers, which you able to try already on current hour.
As additional to this -> with Google Search there possible to find some articles and resources with kind of "instructions" to do trick with certain "intel 3150 video OpenGL 2" (and Windows 7)  trouble... but it looks so not officially and potentially with unexpected result...

 Also under some of topics (with screenshots about "mistake"-view from Freedome) with strings like:
Install a driver providing OpenGL 2.0 or higher, or, if this is not possible, make sure the ANGLE Open GL ES 2.0 emulation libraries (libEGL.dll, libGLEsv2.dll and d3compiler_*.dll) are available in the application executable's directory or in a location listed in PATH.
Where second part (of suggestion) can be useful (or not?!) with some situations.

 

Community Manager

Re: Can't run Freedome because of OpenGl 2.0

Hi MargosDezerian,

 

As mentioned by Ukko, this article he shared has more information about your error message. If you have to get the older version of Freedome to follow the second step, please get in touch with support as mentioned in the article.

Has somebody helped you? Say thanks by giving likes. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
Senior Member

Re: Can't run Freedome because of OpenGl 2.0

Ok,thx to both of you for your help.

Senior Member

Re: Can't run Freedome because of OpenGl 2.0

I contacted the support and got an older version of Freedome. It's running now but the update message is still pops up after each new start of the Netbook.

I tried to change the registry as told here   https://community.f-secure.com/t5/F-Secure/How-to-quot-lock-quot-into-an/m-p/88309

 

but it didn't helped.

Is there any other way to disable the update messages?

Highlighted
Superuser

Re: Can't run Freedome because of OpenGl 2.0

Hello,

 

I re-check with one of my systems (with too much outdated Freedome installation; and with some of recent outdated builds); There partly different results, but editing registry build-number should work;

Maybe not this one which provided (?! and there required some tweaks to official advice), but I able to suggest to try edit value of "Version" to "2" or "1" or current up-to-date build (and not certain build number as 1.8.9999.9999); With my situation (one of them) - it will be useful;

 

Do you able to re-check it with your own experience? Before any official responses... as temporary workaround.

 

Thanks!

 

Spoiler

Also not sure that this is designed, but probably also possible to try trick by related editing registry;

With my own installation there also have strings like "UpdateDownloadUrl" and "UpdateUrl" (additionally to "Version"); Maybe you able to "clean/edit" keys for this; with meanings - if it not possible to download fresh installer - it not possible to trigger notification.
But this ability looks strange;

 // .... but I did not try "restart system" (just restart Freedome) - maybe this is stuck point!

// Looks like that after restart system there also all good; Version-value as "2" (as example) did not trigger notification about "available updates"; With limitation - that with current "outdated" build --> I have to manually check updates for getting such prompt (even with another situation - it was at startup; but maybe there time-delay limits);

 

Senior Member

Re: Can't run Freedome because of OpenGl 2.0

Thx Ukko for your reply. Seems that it works when i put it to 2. After restarting no update prompt.