F-Secure won't start


Re: F-Secure won't start

Yes, and they asked me if I had any other anti-virus software (I don't) or Windows Defender was switched on (it wasn't). Then they sent me an uninstaller and installer, so I reinstalled F-Secure (which I'd already tried, though without using their uninstaller). It's working so far, but last time I reinstalled it also worked for a few days before F-Secure started acting up again. So I'm going to wait for another week or so before I start feeling confident that the issue might be resolved.


Re: F-Secure won't start

@PedroA wrote:

I have exactly the same problem on a ThinkPad W530 Win 7 Pro x64. Uninstalled F-Secure, and reinstalled and didn't help after first reboot. Reinstall installed a new version of F-Secure with different icon colours. I used link from the e-mail I received when buying the subcription and downloaded fresh installer. I will open a support ticket.

We've had few cases where user had Lenovo computer and Lenovo has some kind of optimizer software which disables services. Can you check what is the startup type for 'F-Secure Dll Hoster' service? If it's disabled, change it to 'Automatic'.




Re: F-Secure won't start

Hi I have installed the Unifying program(does it affect....Im not sure if this problem started after I installed the Unifying or before) and I have problems on opening F-Secure it wont start. I tried to uninstall and clean install but nothing changed. Windows just keeps asking me to install Antivirus program. I tried to install the F-Secure from email link but still when I try to open from icon nothing happens and when I try to install again the program it says that I have already the newest version of F-Secure even if it doesnt open.


Little help please Smiley Sad


Re: F-Secure won't start

If something stops working after you installed a program, it's always best to start by uninstalling what you've just installed, to see if that fixes the problem.

Also, when you uninstall F-Secure, did you use the uninstallation tool? If not, that might be worth a try.


Re: F-Secure won't start



Also it's can be related with hard overload. Do you have experience about "waiting" after launch system some of time (more, than usually). And do you have experience about something... such as... what happened - when you try to open F-Secure ?! It's without something as "opening window", without "disk/cpu usage" and without any prompts around?


Such as... what about Task Manager - there should be some of F-Secure processes. You can to check there - if it's with "usage" CPU or drive. Such as.. work or not. Also if there overload.... and for example.. F-Secure goes be with downloading updates...  it's can be long delay before response.


Anyway - also with installation.. you should be available to create "fsdiag" by Support Tool (it should be visible under Menu-list) and with that file..  you able to create ticket for F-Secure Support.

If there something, which goes be same around "conflict' and F-Secure not available to opened as interface.

But Windows can to prompted about "troubles" - because overload with launch system.


Re: F-Secure won't start

Im the same user "tim0"


Yes I did uninstall with F-Secure uninstallation tool but still nothing Smiley Sad icon is on the desktop but nothing happens when I click it nothing opens.


And when I go to Task Manager --> Services there is fshoster F-Secure Dll Hoster but its Stopped Smiley Sad


I dont want to install other Antivirus program because I have license for this and I really want this to work Smiley Sad

As I said before could the reason be logitech unifying receiver driver?


Re: F-Secure won't start



Maybe it's can be related with Logitech Unifying driver.. but if it's like that. Potentially there should be someone else with same experience....  or you able to do "fsdiag" by F-Secure Support Tool (should be as diagnostic tool under F-Secure installation folders) and create ticket for F-Secure Support with current file and description. Such as.. they can to check... what happened and why.


Just I can to add funny point around this.


Yesterday I downloaded Logitech Unifying and it was placed under my one of system. Just as "installer". Not installing it.

Goes to clean/fresh installation of F-Secure. All as always. Installed, downloaded updates/installed updates.. And system/machine was just "idle" some hours.

When I back to system... I get same situation :)  desktop-picture or tray-picture does not trigger opening UI.

I goes to right-click tray-picture. And there was missing information about "ID-codes".

One restart for system - help just with opening UI (but not with ID-codes visible). Some else restarts and all goes be normally. So.. today I was planned to try installing Logitech Unifying and check if it's can be so hard-thing.. if that can to break F-Secure installation... when it simply placed under system as installer-file. :)


But also... F-Secure Dll Hoster.. it's some kind of important thing.

Do you able to check your "msconfig" (by cmd.exe/run) about Services. If F-Secure services disabled?!

You able to "Enabled" it.. Such as for autostart.


Also I will create private letter for you. With one of suggestions also.