F-Secure won't start



When I boot my computer (actually both my desktop computer and laptop), I quite often get a notification that I need to turn on my AntiVirus. F-Secure simply refuses to start. Windows' "turn on AntiVirus software" option doesn't work, and the computer doesn't even seem to react when I click on the F-Secure desktop icon. Meanwhile, fshoster32.exe and FSM32.EXE are both supposedly running.


This happens quite often on the first start-up. Rebooting the computer never works (I've tried both the restart option, and to shut it down and reboot). I've tried opening task manager and ending the F-Secure processes - still can't make it start (neither with desktop icon nor run-commands). I've tried reinstalling - it works until I reboot the computer.


I wanted to include the log file, but I don't know where it is.


I'm running the latest version of F-Secure (installed just a few days ago - though the last version gave me the same problem) on a Windows 7 system (desktop computer runs on 64-bit, and I think my laptop does too).


I've run scans in instances where F-Secure works, and they always turn up empty.


Could someone please help me try and solve the problem?


  • Simon
    Simon Posts: 2,665 Superuser

    Hi there!  :)


    It sounds like a possible conflict with other software.  Do you have any other anvi-virus or anti spyware / malware products running in real time on the machine, or did you remove another security app before installing F-Secure?


    If not, then I think you'll need to raise a Support Ticket, including an FSDIAG from the Support Tool, so the tech guys can look at your system.

  • Thanks for your reply :)


    No, I'm pretty sure I don't have any other software like that. Windows Defender is turned off, and that's the only other program in that category I can find.

  • I tried turning off the computer and then wait for a few minutes before turning it back on again, and now F-Secure is working again. But chances are it's going to start acting up again the next time I boot my computer.

  • Simon
    Simon Posts: 2,665 Superuser

    OK, the only other thing I can suggest is to try removing F-Secure with the F-Secure Uninstallation Tool and reinstall it - but I think, if this is happening on two separate machines, your best bet is to send in a support ticket with an FSDAIG, as there may be something on both of them causing the issue.

  • PedroA
    PedroA Posts: 3 New Member

    I have exactly the same problem on a ThinkPad W530 Win 7 Pro x64. Uninstalled F-Secure, and reinstalled and didn't help after first reboot. Reinstall installed a new version of F-Secure with different icon colours. I used link from the e-mail I received when buying the subcription and downloaded fresh installer. I will open a support ticket.

  • PedroA
    PedroA Posts: 3 New Member

    Do you have Logitech's Unity driver installed? It might have been the culprit in my case... not yet sure... but it would be good if you could let us know if you also have Unity installed.


  • No, I don't have Logitech Unity installed.


    I contacted customer support, and then sent me some special 'uninstaller' which I used, and then I reinstalled F-Secure. I've tried reinstalling before, and it's worked for a few days, and then F-Secure starts acting up again. I'm anxious to see if it actually worked this time, though I'm not too confident...

  • Pekko
    Pekko Posts: 27 F-Secure Product Expert

    Hello Arcadian and Pedro,


    have you guys opened a ticket with our Support team? Is the issue solved or do you have any news about it?

  • PedroA
    PedroA Posts: 3 New Member

    Yes, I openned  a ticket about five days ago, and sent another message a couple of days later. I received no answer, but it looks like I managed to solve the problem myself by uninstalling Logitech's Unity Driver and using a different mouse. As the problem was sometimes intermitent, I cannot say for sure that this was a complete solution, but at least F-Secure has been working as expected since yesterday, and with 3 or 4 restarts (for other reasons than errors).

  • Yes, and they asked me if I had any other anti-virus software (I don't) or Windows Defender was switched on (it wasn't). Then they sent me an uninstaller and installer, so I reinstalled F-Secure (which I'd already tried, though without using their uninstaller). It's working so far, but last time I reinstalled it also worked for a few days before F-Secure started acting up again. So I'm going to wait for another week or so before I start feeling confident that the issue might be resolved.

  • Late
    Late Posts: 10 F-Secure Employee

    @PedroA wrote:

    I have exactly the same problem on a ThinkPad W530 Win 7 Pro x64. Uninstalled F-Secure, and reinstalled and didn't help after first reboot. Reinstall installed a new version of F-Secure with different icon colours. I used link from the e-mail I received when buying the subcription and downloaded fresh installer. I will open a support ticket.

    We've had few cases where user had Lenovo computer and Lenovo has some kind of optimizer software which disables services. Can you check what is the startup type for 'F-Secure Dll Hoster' service? If it's disabled, change it to 'Automatic'.



  • tim0
    tim0 Posts: 1

    Hi I have installed the Unifying program(does it affect....Im not sure if this problem started after I installed the Unifying or before) and I have problems on opening F-Secure it wont start. I tried to uninstall and clean install but nothing changed. Windows just keeps asking me to install Antivirus program. I tried to install the F-Secure from email link but still when I try to open from icon nothing happens and when I try to install again the program it says that I have already the newest version of F-Secure even if it doesnt open.


    Little help please Smiley Sad

  • Simon
    Simon Posts: 2,665 Superuser
    If something stops working after you installed a program, it's always best to start by uninstalling what you've just installed, to see if that fixes the problem.

    Also, when you uninstall F-Secure, did you use the uninstallation tool? If not, that might be worth a try.

  • Ukko
    Ukko Posts: 3,603 Superuser



    Also it's can be related with hard overload. Do you have experience about "waiting" after launch system some of time (more, than usually). And do you have experience about something... such as... what happened - when you try to open F-Secure ?! It's without something as "opening window", without "disk/cpu usage" and without any prompts around?


    Such as... what about Task Manager - there should be some of F-Secure processes. You can to check there - if it's with "usage" CPU or drive. Such as.. work or not. Also if there overload.... and for example.. F-Secure goes be with downloading updates...  it's can be long delay before response.


    Anyway - also with installation.. you should be available to create "fsdiag" by Support Tool (it should be visible under Menu-list) and with that file..  you able to create ticket for F-Secure Support.

    If there something, which goes be same around "conflict' and F-Secure not available to opened as interface.

    But Windows can to prompted about "troubles" - because overload with launch system.

  • tim0s
    tim0s Posts: 1

    Im the same user "tim0"


    Yes I did uninstall with F-Secure uninstallation tool but still nothing Smiley Sad icon is on the desktop but nothing happens when I click it nothing opens.


    And when I go to Task Manager --> Services there is fshoster F-Secure Dll Hoster but its Stopped Smiley Sad


    I dont want to install other Antivirus program because I have license for this and I really want this to work Smiley Sad

    As I said before could the reason be logitech unifying receiver driver?

  • Ukko
    Ukko Posts: 3,603 Superuser



    Maybe it's can be related with Logitech Unifying driver.. but if it's like that. Potentially there should be someone else with same experience....  or you able to do "fsdiag" by F-Secure Support Tool (should be as diagnostic tool under F-Secure installation folders) and create ticket for F-Secure Support with current file and description. Such as.. they can to check... what happened and why.


    Just I can to add funny point around this.


    Yesterday I downloaded Logitech Unifying and it was placed under my one of system. Just as "installer". Not installing it.

    Goes to clean/fresh installation of F-Secure. All as always. Installed, downloaded updates/installed updates.. And system/machine was just "idle" some hours.

    When I back to system... I get same situation :)  desktop-picture or tray-picture does not trigger opening UI.

    I goes to right-click tray-picture. And there was missing information about "ID-codes".

    One restart for system - help just with opening UI (but not with ID-codes visible). Some else restarts and all goes be normally. So.. today I was planned to try installing Logitech Unifying and check if it's can be so hard-thing.. if that can to break F-Secure installation... when it simply placed under system as installer-file. :)


    But also... F-Secure Dll Hoster.. it's some kind of important thing.

    Do you able to check your "msconfig" (by cmd.exe/run) about Services. If F-Secure services disabled?!

    You able to "Enabled" it.. Such as for autostart.


    Also I will create private letter for you. With one of suggestions also.

This discussion has been closed.
Pricing & Product Info