F-Secure and Internet Explorer 11 incompatibility

Senior Advisor

Re: F-Secure and Internet Explorer 11 incompatibility

@macstorm 

 

Prior to full compatibility of F-Secure IS and IE11, you had to disable the EPM in Internet Explorer for the online Safety add-on to function properly.(see the first post in this thread). So then the EPM did affect the compatibility of the add-on; now it does not.

 

But for optimum protection, if you use IE as your main browser, you are recommended to make sure that EPM is running together with F-Secure's Online Safety add-on (particularly as Microsoft released an update disabling EPM!-https://support.microsoft.com/kb/2907803).

Highlighted
Supporter

Re: F-Secure and Internet Explorer 11 incompatibility

@Blackcat 

 

Yes, I was aware of the MS decision to disable EPM through WindowsUpdate last month, but I didn't know that FSIS wasn't fully compatible with EPM because I hadn't it installed at that time. I'm glad everything is ok now. Thank you for your help.

 

Happy New Year everyone!