F-Secure Internet Security vanished with update process

Scholar

F-Secure Internet Security vanished with update process

My F-Secure Internet Security started to update itself, but in the middle of the process it failed with error message (translation from Finnish error message): "F-Secure Host Process stopped working and was closed. Application stopped with error because of a problem. Windows will notify if there is a solution".

Now I cannot find the F-Secure user interface anymore from my computer Start menu or from desktop. It is not also in Control Panel - Programs. Anyhow the files are still located in C:/Program Files/F-Secure... Also Control Panel - Security Center informs that F-Secure is protecting the computer.

How can I fix the F-Secure? Tried to reinstall by downloading 2013 version from F-Secure site and also from CD but both fail with every try to "Unsuccessful Installation" error.

I am using Windows Vista Service Pack 2, 32 bit.

1 REPLY 1
F-Secure Product Expert
F-Secure Product Expert

Re: F-Secure Internet Security vanished with update process

Hello Ville12345,

 

In order to clarify the status of the protection on your machine and solve your problem, please open a support ticket and provide fsdiag.

 

 

Thank you.



Best Regards

-Ben

_________________________________

Has somebody helped you? Say thanks by giving likes. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.