Browsing Protection in Firefox v57

Scholar

Browsing Protection in Firefox v57

Recently, Firefox (v57) has disabled Browsing Protection by F-Secure (see messages below).  Are there any plans to support this?

 

"Browsing Protection by F-Secure could not be verified for use in Firefox and has been disabled."

 

"Starting in Firefox version 57, only extensions built using WebExtensions APIs will work."

1 ACCEPTED SOLUTION

Accepted Solutions
Superuser

Re: Browsing Protection in Firefox v57

Hello,

 

Not an F-Secure problem!

 

The Mozilla foundation has messed up the signing certificate expiry for all Firefox web browser extensions and add-ons, thereby making them invalid during late Friday. It is a huge issue right now and an urgent FF fix is under testing. Read more about it there:

 

https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/...

 

https://bugzilla.mozilla.org/show_bug.cgi?id=1548973

 

Yours Sincerely: Tamas Feher, Hungary.

 

 

View solution in original post

9 REPLIES 9
Scholar

Re: Browsing Protection in Firefox v57

I am also getting the same message using Firefox V66.0.3 What is going on ?

 

Peterdee

Superuser

Re: Browsing Protection in Firefox v57


@Kriton wrote:

Recently, Firefox (v57) has disabled Browsing Protection by F-Secure (see messages below).  Are there any plans to support this?

 

"Browsing Protection by F-Secure could not be verified for use in Firefox and has been disabled."

 

"Starting in Firefox version 57, only extensions built using WebExtensions APIs will work."


Hello,

 

I am only an F-Secure user (their home solutions).

// later added: It is looks like that it is popular trouble with Firefox 66.0.3; at least, web with a lot of discussions about situation where addons got disabled and marked as legacy. One example is reddit: https://www.reddit.com/r/firefox/comments/bkcjoa/all_of_my_addons_got_disabled_and_they_are_all/

and another one is superuserCom: https://superuser.com/questions/1432789/all-of-my-firefox-add-ons-been-disabled-suddenly-how-can-i-r...


At the time - there was a discussion about Firefox 57 changes:

And it is sorted after that. So, most of recent F-Secure solutions with support for these changes.

 

Good to know: what is your OS / platform(?) and what is your F-Secure solution(?). And, maybe, what is version of F-Secure Browsing Protection addon?

 

By the way, if there a reason to use Firefox 57? While sounds that there are much more fresher updates are available for Firefox?

 


@Peterdee wrote:

I am also getting the same message using Firefox V66.0.3 What is going on ?

Peterdee


Perhaps, I tried Firefox 66.0.3 recently with beta F-Secure SAFE solution. All was OK with addon.

Does your experience is about "today"? And does it appeared right after upgrade to Firefox 66.0.3?

 

Did you try to reinstall F-Secure Browsing Protection addon via F-Secure user interface (for Windows):

But good to know what is your OS / platform. And what is your F-Secure solution.

// It is looks like that it is popular trouble with Firefox 66.0.3; at least, web with a lot of discussions about situation where addons got disabled and marked as legacy. One example is reddit: https://www.reddit.com/r/firefox/comments/bkcjoa/all_of_my_addons_got_disabled_and_they_are_all/

and another one is superuserCom: https://superuser.com/questions/1432789/all-of-my-firefox-add-ons-been-disabled-suddenly-how-can-i-r...

Thanks!

Highlighted
Scholar

Re: Browsing Protection in Firefox v57


@Ukko wrote:

@Kriton wrote:

Recently, Firefox (v57) has disabled Browsing Protection by F-Secure (see messages below).  Are there any plans to support this?

 

"Browsing Protection by F-Secure could not be verified for use in Firefox and has been disabled."

 

"Starting in Firefox version 57, only extensions built using WebExtensions APIs will work."


Hello,

 

I am only an F-Secure user (their home solutions).

// later added: It is looks like that it is popular trouble with Firefox 66.0.3; at least, web with a lot of discussions about situation where addons got disabled and marked as legacy. One example is reddit: https://www.reddit.com/r/firefox/comments/bkcjoa/all_of_my_addons_got_disabled_and_they_are_all/

and another one is superuserCom: https://superuser.com/questions/1432789/all-of-my-firefox-add-ons-been-disabled-suddenly-how-can-i-r...


At the time - there was a discussion about Firefox 57 changes:

And it is sorted after that. So, most of recent F-Secure solutions with support for these changes.

 

Good to know: what is your OS / platform(?) and what is your F-Secure solution(?). And, maybe, what is version of F-Secure Browsing Protection addon?

 

By the way, if there a reason to use Firefox 57? While sounds that there are much more fresher updates are available for Firefox?

 


@Peterdee wrote:

I am also getting the same message using Firefox V66.0.3 What is going on ?

Peterdee


Perhaps, I tried Firefox 66.0.3 recently with beta F-Secure SAFE solution. All was OK with addon.

Does your experience is about "today"? And does it appeared right after upgrade to Firefox 66.0.3?

 

Did you try to reinstall F-Secure Browsing Protection addon via F-Secure user interface (for Windows):

But good to know what is your OS / platform. And what is your F-Secure solution.

// It is looks like that it is popular trouble with Firefox 66.0.3; at least, web with a lot of discussions about situation where addons got disabled and marked as legacy. One example is reddit: https://www.reddit.com/r/firefox/comments/bkcjoa/all_of_my_addons_got_disabled_and_they_are_all/

and another one is superuserCom: https://superuser.com/questions/1432789/all-of-my-firefox-add-ons-been-disabled-suddenly-how-can-i-r...

Thanks!


Hello Ukko,

fyi; encountered the same problem today after Firefox was uodated to 66.0.3. I'm Using F-Secure Safe and the Browsing protection is version 2.220.7818, on a Windows 10 (1809) Home system ( version 17763.475.)  I did try with re-install the browser pritection add-on but no result.

Any suggestions?

Thanks and best regards

Superuser

Re: Browsing Protection in Firefox v57

Hello,

 

Not an F-Secure problem!

 

The Mozilla foundation has messed up the signing certificate expiry for all Firefox web browser extensions and add-ons, thereby making them invalid during late Friday. It is a huge issue right now and an urgent FF fix is under testing. Read more about it there:

 

https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/...

 

https://bugzilla.mozilla.org/show_bug.cgi?id=1548973

 

Yours Sincerely: Tamas Feher, Hungary.

 

 

View solution in original post

Scholar

Re: Browsing Protection in Firefox v57

Sorry, I meant to say "since v57".  Yeah, after further research, I see that it is a Mozilla issue.  Thanks everyone!

Superuser

Re: Browsing Protection in Firefox v57

Hello,

 

The problem is now fixed: Mozilla foundation has released a new minor version (Firefox 66.0.4) for all platforms, which re-enables the extensions and add-ons.

 

Best Regards: Tamas Feher, Hungary.

 

 

Scholar

Re: Browsing Protection in Firefox v57

Noticed it, everything works OK by me now
Scholar

Re: Browsing Protection in Firefox v57

Thanks for your help and confirm 66.0.4 has sorted it.

Peterdee

Aspirant

Re: Browsing Protection in Firefox v57

Hi, i got nowhere with 68.0.1 firefox.. not one page loads, with or without browsing protection. firefox issue ?