Any progress for BP compatibility with Firefox 10?

Supporter

Any progress for BP compatibility with Firefox 10?

Just curious why F-Secure was caught not ready after doing farly good job of preparing Browsing Protection on time for last few FF releases.

71 REPLIES 71
Community Manager

Re: Any progress for BP compatibility with Firefox 10?

Hi Andrzej,

 

Our plan is, with all Firefox releases, to provide an update supporting the new version within 2 weeks of the Firefox release.

 

Cheers,

Stephan

Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
Superuser

Re: Any progress for BP compatibility with Firefox 10?

Hi,

 

as I already stated in the German threads:

it is not acceptableto leave all FF-Useres unprotected for 1/3 of the time. In two weeks we see FF10.01 and in 6 weeks we see FF11.

 

BR

 

Matthias
----------
perComp is a Platinum Partner of F-Secure since 1994. Any advice or help given by me in this forum is voluntarily and to my best knowledge based on working with the products since 1997. Direct contact for customers please check our homepage http://www.percomp.de

Supporter

Re: Any progress for BP compatibility with Firefox 10?

I am afraid that 2 weeks is not good enough for average (less computer savvy) user who might upgrade Firefox automatically, then be left without browser protection.

Superuser

Re: Any progress for BP compatibility with Firefox 10?

This was posted today:

There's a new browsing protection release candidate available

The update contains stability fixes and provides support for Firefox 10

The visible version string is "F-Secure Browsing Protection SW Update 2012-02-07_01"

The update is distributed through the policy manager which has been configured as specified in the instruction page: http://www.f-secure.com/en_EMEA-Labs/beta-programs/business-users-beta/beta-update-channel/instructi...

Manual installation packages for all current release candidates are available as follows:

on windows:
for 9-series in http://download.f-secure.com/latest/beta/fsdbupdate9.exe

The executables are self-installing on a system with the appropriate F-secure client. These manual installation packages also contain other engines we currently have in a release candidate state, which are due to production later.

For any feedback regarding the update or the beta program, please send them through corp-beta@f-secure.com

Thanks and Best Regards:
F-Secure Labs

Matthias
----------
perComp is a Platinum Partner of F-Secure since 1994. Any advice or help given by me in this forum is voluntarily and to my best knowledge based on working with the products since 1997. Direct contact for customers please check our homepage http://www.percomp.de

Supporter

Re: Any progress for BP compatibility with Firefox 10?

10.1 is out and not compatible with last week F-Secure Beta release

At this pace we can simply ask F-Secure to cross off the advertised feature of Browsing proteection for Firefox

Scholar

Re: Any progress for BP compatibility with Firefox 10?

I downgraded my Firefox to 3.6 due to such problems. One of the things I hate about Mozilla is that it always upgrades from time to time until other software will be too late to catch up.

 

 

______________

Business is the game!!

Supporter

Re: Any progress for BP compatibility with Firefox 10?

Acceptable alternative solution as long as Firefox maintains security patches for 3.6.x

Superuser

Re: Any progress for BP compatibility with Firefox 10?

And what about the numerous plugins and addons?

Who is keeping them up to date?

The old ones still have all the security issues that were discoverd since 3.6...

Matthias
----------
perComp is a Platinum Partner of F-Secure since 1994. Any advice or help given by me in this forum is voluntarily and to my best knowledge based on working with the products since 1997. Direct contact for customers please check our homepage http://www.percomp.de

F-Secure

Re: Any progress for BP compatibility with Firefox 10?

Hello,

 

1 important point to mention is that if you do use the package in http://download.f-secure.com/latest/beta/fsdbupdate9.exe, you need to run it in command prompt with extra parameters for BP to get installed:

fsdbupdate9 -f

 

We're aware of this limitation, and a bug case has been raised for future improvement. Sorry for the inconveniences.

 

About having support 2 weeks after Firefox RTM, we still need to test the final RTM package to ensure that the final release does not have any changes that might break BP. We are already exploring alternatives to match up to Mozilla's rapid release, but for the time being this is what we can offer.

Regards,
Tack
F-Secure Customer Care