Old expiry date showing on my Mac after renewing my F-Secure SAFE subscription Symptoms
I have renewed my F-Secure SAFE subscription but the product still shows the old expiry date.
Diagnosis
Once you have renewed your subscription, there is no further action required by you. The product on your device gets updated automatically. However, this update may take a few hours. The old expiry date may show until your product is updated.
Solution
To check for updates on your Mac manually, do the following:
- Open F-Secure SAFE by clicking the F-Secure icon on the top-right side of the menu bar.
- Click the Tools tab.
- Click Check for updates. The Check for updates dialog opens. The product checks for updates from our server and downloads them if new updates are available.
Once the checking for updates is completed, your product is up to date, and the new expiry date will show.