SAFEn ja Browser Consolen ilmoituksia - mistähän on kysymys?

Timo_NTimo_N Viestejä: 2

Uudehkolla Macilla on SAFE huomautellut harvakseltaan, että olen muka asentanut Firefoxille selauksen suojauksen laajennuksen. Kai sitten niin, mutta muistaakseni olen asentanut SAFEn ja Firefoxin jälkeen vain tarjottuja päivityksiä. Sitten muutamia kertoja on myös Browser Console näyttänyt sellaisia ilmoituksia kuin oheisen lokin alussa "XML-jäsennysvirhe: XML ei ole hyvämuotoista".

 

Kysymykseni: näyttääkö tuossa tekstissä olevan mitään sellaista, joka pitäisi tarjota jonkin toimijan selvitettäväksi? Minusta maallikkona näyttää, että jokin ohjelma kaipaa jotakin puuttuvaa, mutta kun Firefox tuntuu toimivan normaalisti, en tunnista korjausta vaativaa virhetilannetta.

 

Timo N

--------------------

Tässä on Browser Consolelta leikepöydän kautta kopioimani teksti.

-------------

OpenGL compositor Initialized Succesfully.

Version: 2.1 ATI-1.66.31

Vendor: ATI Technologies Inc.

Renderer: AMD Radeon Pro 555 OpenGL Engine

FBO Texture Target: TEXTURE_2D

TypeError: gURLBar is null[Learn More]  browser.js:8671:9

Use of Mutation Events is deprecated. Use MutationObserver instead.  jquery.js:3:8806

OpenGL compositor Initialized Succesfully.

Version: 2.1 ATI-1.66.31

Vendor: ATI Technologies Inc.

Renderer: AMD Radeon Pro 555 OpenGL Engine

FBO Texture Target: TEXTURE_2D<unavailable>  activity-stream.bundle.js:2615:9

TypeError: gebi(...) is null  w:592:3

XML-jäsennysvirhe: XML ei ole hyvämuotoista

URL: http://127.0.0.1:49604/configupdate?browser=firefox&version=1033

Rivinumero 1, sarake 1:  configupdate:1:1

1527585439302                 addons.update-checker      WARN           onUpdateCheckComplete failed to parse update manifest: [Exception... "Update manifest is missing a required addons property."  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/modules/addons/AddonUpdateChecker.jsm :: getRequiredProperty :: line 461"  data: no] Stack trace: getRequiredProperty()@resource://gre/modules/addons/AddonUpdateChecker.jsm:461

parseJSONManifest()@resource://gre/modules/addons/AddonUpdateChecker.jsm:471

parser()@resource://gre/modules/addons/AddonUpdateChecker.jsm:631

onLoad()@resource://gre/modules/addons/AddonUpdateChecker.jsm:651

UpdateParser/<()@resource://gre/modules/addons/AddonUpdateChecker.jsm:576

1527585439311                 addons.update-checker      WARN           onUpdateCheckComplete failed to parse update manifest: [Exception... "Update manifest is missing a required addons property."  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/modules/addons/AddonUpdateChecker.jsm :: getRequiredProperty :: line 461"  data: no] Stack trace: getRequiredProperty()@resource://gre/modules/addons/AddonUpdateChecker.jsm:461

parseJSONManifest()@resource://gre/modules/addons/AddonUpdateChecker.jsm:471

parser()@resource://gre/modules/addons/AddonUpdateChecker.jsm:631

onLoad()@resource://gre/modules/addons/AddonUpdateChecker.jsm:651

UpdateParser/<()@resource://gre/modules/addons/AddonUpdateChecker.jsm:576

1527585439321                 addons.update-checker      WARN           onUpdateCheckComplete failed to parse update manifest: [Exception... "Update manifest is missing a required addons property."  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/modules/addons/AddonUpdateChecker.jsm :: getRequiredProperty :: line 461"  data: no] Stack trace: getRequiredProperty()@resource://gre/modules/addons/AddonUpdateChecker.jsm:461

parseJSONManifest()@resource://gre/modules/addons/AddonUpdateChecker.jsm:471

parser()@resource://gre/modules/addons/AddonUpdateChecker.jsm:631

onLoad()@resource://gre/modules/addons/AddonUpdateChecker.jsm:651

UpdateParser/<()@resource://gre/modules/addons/AddonUpdateChecker.jsm:576

1527585439332                 addons.update-checker      WARN           onUpdateCheckComplete failed to parse update manifest: [Exception... "Update manifest is missing a required addons property."  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/modules/addons/AddonUpdateChecker.jsm :: getRequiredProperty :: line 461"  data: no] Stack trace: getRequiredProperty()@resource://gre/modules/addons/AddonUpdateChecker.jsm:461

parseJSONManifest()@resource://gre/modules/addons/AddonUpdateChecker.jsm:471

parser()@resource://gre/modules/addons/AddonUpdateChecker.jsm:631

onLoad()@resource://gre/modules/addons/AddonUpdateChecker.jsm:651

UpdateParser/<()@resource://gre/modules/addons/AddonUpdateChecker.jsm:576

1527585439371                 addons.update-checker      WARN           onUpdateCheckComplete failed to parse update manifest: [Exception... "Update manifest is missing a required addons property."  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/modules/addons/AddonUpdateChecker.jsm :: getRequiredProperty :: line 461"  data: no] Stack trace: getRequiredProperty()@resource://gre/modules/addons/AddonUpdateChecker.jsm:461

parseJSONManifest()@resource://gre/modules/addons/AddonUpdateChecker.jsm:471

parser()@resource://gre/modules/addons/AddonUpdateChecker.jsm:631

onLoad()@resource://gre/modules/addons/AddonUpdateChecker.jsm:651

UpdateParser/<()@resource://gre/modules/addons/AddonUpdateChecker.jsm:576

1527585439507                 addons.update-checker      WARN           onUpdateCheckComplete failed to parse update manifest: [Exception... "Update manifest is missing a required addons property."  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/modules/addons/AddonUpdateChecker.jsm :: getRequiredProperty :: line 461"  data: no] Stack trace: getRequiredProperty()@resource://gre/modules/addons/AddonUpdateChecker.jsm:461

parseJSONManifest()@resource://gre/modules/addons/AddonUpdateChecker.jsm:471

parser()@resource://gre/modules/addons/AddonUpdateChecker.jsm:631

onLoad()@resource://gre/modules/addons/AddonUpdateChecker.jsm:651

UpdateParser/<()@resource://gre/modules/addons/AddonUpdateChecker.jsm:576

1527585439515                 addons.update-checker      WARN           onUpdateCheckComplete failed to parse update manifest: [Exception... "Update manifest is missing a required addons property."  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/modules/addons/AddonUpdateChecker.jsm :: getRequiredProperty :: line 461"  data: no] Stack trace: getRequiredProperty()@resource://gre/modules/addons/AddonUpdateChecker.jsm:461

parseJSONManifest()@resource://gre/modules/addons/AddonUpdateChecker.jsm:471

parser()@resource://gre/modules/addons/AddonUpdateChecker.jsm:631

onLoad()@resource://gre/modules/addons/AddonUpdateChecker.jsm:651

UpdateParser/<()@resource://gre/modules/addons/AddonUpdateChecker.jsm:576

1527585439524                 addons.update-checker      WARN           onUpdateCheckComplete failed to parse update manifest: [Exception... "Update manifest is missing a required addons property."  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/modules/addons/AddonUpdateChecker.jsm :: getRequiredProperty :: line 461"  data: no] Stack trace: getRequiredProperty()@resource://gre/modules/addons/AddonUpdateChecker.jsm:461

parseJSONManifest()@resource://gre/modules/addons/AddonUpdateChecker.jsm:471

parser()@resource://gre/modules/addons/AddonUpdateChecker.jsm:631

onLoad()@resource://gre/modules/addons/AddonUpdateChecker.jsm:651

UpdateParser/<()@resource://gre/modules/addons/AddonUpdateChecker.jsm:576

1527585800148                 app.normandy.recipe-runner                   WARN           Could not fetch implementation for preference-rollout:: TypeError: url is null (resource://normandy/lib/NormandyApi.jsm:60:1) JS Stack trace: [email protected]:60:1

[email protected]:173:39

[email protected]:304:38

1527585800149                 app.normandy.recipe-runner                   WARN           Could not fetch implementation for preference-rollback:: TypeError: url is null (resource://normandy/lib/NormandyApi.jsm:60:1) JS Stack trace: [email protected]:60:1

[email protected]:173:39

[email protected]:304:38

 

Paras vastaus

  • FS_EkkuFS_Ekku Viestejä: 206 Moderator
    Vastaus ✓

    Hei,

     

    Mikään lokissa näkyvä merkintä ei näytä liittyvän F-securen selainlaajennukseen. Voit tarkastaa, että toimiiko F-securen Browsing Protection selainlaajennus normaalisti, jos Googlen hakutulosten vasemmalla puolella näkyy merkintä, joka kertoo sivuston luotettavuuden. Se on F-secure Browsing Protectionin ominaisuus.

    Timo_N

Viestejä yhteensä

  • Timo_NTimo_N Viestejä: 2

    Kyllä hakutuloksien alussa on pieni täppä, yleensä vihreä mutta kokeilemalla löytyi myös musta kysymysmerkki. Koska tätä ei tule vanhentuneella macilla (OS X 10.10.5) jolle ensin yritin asentaa SAFEn, uudella konella (macOS 10.13.4) tuo suojaus / varoitus ilmeisesti toimii. 

    Timo N

Tämä keskustelu on suljettu.