Java

Do I need Java with F-secure Safe 16.5? I have Java 8. Must I update it?

Best Answer

  • UkkoUkko Posts: 2,999 Superuser
    Accepted Answer

    Hello,

     

    Sorry for my reply, but probably Java is not required for F-Secure SAFE.

     

    You able to re-check system-technical-requirements for F-Secure SAFE with this URL:

    https://www.f-secure.com/en/web/home_global/safe#technical-details-download

     

    Also there can be official support for three browsers: Internet Explorer (and Microsoft Edge, but with some limitation), Firefox (two latests main builds), Google Chrome (two latests main builds);

    Laksh
This discussion has been closed.