Chrome for Android does not appear in Safe Browsing list

Hello everyone,

I've two android devices with Chrome browser.

On my Nexus 4 with Android 5.1 everything works fine, instead on my eXperia Z2 with Android 6 I can't see Chrome listed in Safe Browsing section.

I mean in Safe Browsing Menu (tap to F-Secure SAFE app, then tap to Safe Browsing icon).

Actually if I browse some suspicious website with Chrome on my Nexus 4, it reacts with an F-Secure popup, eXperia Z2 doesn't.

What could I do?

F_Secure's support couldn't help me.

Thank you.


  • SimonSimon Posts: 2,658 Superuser
    If F-Secure Support couldn't help, I'm not sure if there's anything we can do. What did they actually say? Have you tried re-installing the app on the troublesome device?
  • vash83vash83 Posts: 5

    I think they don't know the product so well. I spoke with chat support. Initially they said me that Chrome isn't supported but it's false othewise why does it work on my Nexus? Furthermore they said that Chrome is protected by basic SAFE protection. I didn't have eXperia close to me at that moment so I couldn't try the test page where the popo-up appeared, so I had to close the chat support. I didn't try to reinstall app yet.

    Below i post the two screenshots:



  • SimonSimon Posts: 2,658 Superuser

    Sorry, I'm no expert on the mobile apps, and I'm afraid I only speak English, so I've no idea what either of those screenshots say.  My suggestion to re-install was just a basic idea.  Perhaps there is something in the eXperia software which prevents the app from working properly, or maybe the Android version is out of date, or incompatible?


    If you don't get any more responses on here, then I suggest that you submit a Support Ticket, giving as much detail as you can about the problem, and hopefully they will be able to help.

  • vash83vash83 Posts: 5

    Thank you so much Simon.

    Both screenshots say that Browsing protection is ok. Sorry about foreign languages.

    Outdated Android version is not the case. Nexus is 5.1 and eXperia 6.x, probably eXperia is not compatible or is Japanese language a problem? Strange... I hope someone will answer me here and anyway I'll open a support ticket. Thank you so much for the support ticket link.

  • forazforaz Posts: 2
    I have exactly the same problem on my S5. It works on my tablet, on a s5 mini, but chrome doesnt show up as protected on my s5.
  • vash83vash83 Posts: 5


    Which Android version are you running?

    I opened a ticket support and they told me that device is automatically protected anyway. But it's not true, because I don't receive alerts while I'm browsing a suspicious website that on my nexus triggers it instead.

    Thank you for your reply, I hope that F-Secure team can solve that issue. I'm evaluating this products and this problem could be the thing that make me decide which product I'm going to buy.


  • I think f-secure safe browse protection doesn't support 6.0.1 and up because my device (priv 6.0.1) have the same problem.
  • vash83vash83 Posts: 5


    thank you for your answer.

    I agree, probably the problem is Android's version 6.0.1, also my Sony has it onboard.

    So...  does anyone have the same version and can report it to us? 

    What should we do? Should we open a new thread?New support ticket?

    I did a further test, I tried to visit websites suggested by F-Secure to test browsing protection, the following recommended by F-Secure on this thread(



    I also tried the four tests proposed here:




    Chrome: All tests failed

    F-Secure Safe Browsing: All tests successful


    That means tha Chrome IS NOT protected even though F-Secure support told me the opposite.




  • forazforaz Posts: 2

    I have Android 6.0.1 on my S5. Problem still not solved..hope this helps others..

This discussion has been closed.