Freedome subscription not working

Ok, this is what happened. I used the 14 day free trial thing, and when i entered a subscripyion code, this message appeared: You cannot use this code because you have already used another one on this device. Even when I reinstalled Freedome, it showed the same message. Can anyone please help!


P.S. Using Windows 8, on PC


  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hi Colecr,


    May I know how did you purchase your Freedome code which is being validated on your device? Please also let us know how many devices can use this code.

  • i am not sure how my friend bought his subscription, but I have now sent a invite to my friends, and as such as part of the promotion, I received a years worth of Freedome, the voucher code which I managed to validate. However, now, the sign just keeps saying Connecting... 

  • please am having the same problem too and my key can work with three computers. i bought the code via paypal through cleverbridege. the three system where work fine with the ke. so i update one of the device which i had to remove the freedome software so after am done i tried to install it back but it wont let me

  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hi Colecr,


    Is this a code which was purchased by your friend? May I know more information on the code as to how it was purchased? Have you used this code before on any of your computers and validated it?


    This will help us to understand about the code purchased and to check further.

  • Please I would like also to know what to do with my last key that won't work on my computer thanks
  • aquaguard
    aquaguard Posts: 1 New Member
    Same issue here, on iPad, trial expired, want to use code obtained from a computer fair, same error message, how to make this code works or remove the original code on iPad? Urgent.
  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hi aquaguard,


    May I know further information on the code which you purchased - is it a single license or a multi license code?


    If the trial period is expired on your iPad, does the error occurs when you try to validate this code in your iPad? If you have no codes in your Freedome product (since trial expired), have you tried to uninstall and reinstall using the code you purchased?


    Is there any other devices in which you have used this code?

This discussion has been closed.
Product & Pricing Info