Freedome VPN 2.0.4 for iOS released

TapsaTapsa Posts: 82 F-Secure Employee

We just released Freedome VPN 2.0.4 to the App Store after Apple review was completed this morning!

 

This version includes fixes to the VPN connection problems you've reported to us. 

 

If you have Freedome VPN installed on your device, you will receive the new version as an update. Open the App Store icon and you will see the new version offered there on the Updates tab.

 

If your device is still running iOS 8.0.0 operating system, we recommend you to update it also to version 8.0.2 as it contains fixes for VPN use too.

 

After these updates, make sure that F-Secure Freedome VPN is turned on. After that it should always stay on until you turn it off yourself - for example it will be turned on after reboot of the device, as long as it was turned on before the reboot.

 

We are very sorry for these problems and that it took this long to get the new version out.

Acronymous

Accepted Answer

Comments

  • RelexRelex Posts: 12
    Just updated to FREEDOME 2.0.4. While running on IOS 2.0.2
    Problem with shutting of persists !
    Tried again first deleting and resetting Iphone,
    then turn of and turn on.
    Also after this the VPN keeps **bleep**ting down.SPINTANIOUSLY.
    Sometines giving the message
    ERROR INITIATING VPN CONNECTION
    Earthpilot
  • Install the recent version didn't solve the problem for me.

    i removed the vpn-profile, uninstalled the app, restarted iphone/ipad and then i reinstalled the app. Now everything woks fine.

  • StooStoo Posts: 13

    It's still acting very glitchy on my phone. Smiley Sad

    I've uninstalled/reinstalled the VPN profile and rebooted my phone.

    Freedome still keeps turining itself off.

  • Still the same problem. I have also removed the profile and tried to install again a few times with a few restarts.

    StooEarthpilot
  • Problem persists. It is very unfortunate that new version was released and said that it would solve the problem. Come on guys! Please do not hesitate to contact me should you need someone to test the product BEFORE the launch. Now it seems that there were no changes compared to previous version. Surprised? No. Disappointed? Yes. You dropped the ball and now you should listen your clients when you still have few left.

    At the moment Freedome is like communism, excellent idea but implementation is not so good.
  • MihoMiho Posts: 16
    One question, do I have to install the profile every time I change the location? (is this a design of the new version 2.0.4?)
  • Hi,
    Unfortunately not very much improvment. I have been testing version 2.0.4 the whole day and the VPN connection keeps dropping off quite often and randomly. The only change is that sometimes the connection resumes by itself, but normally it stays off until I go back to Freedome and switch on manually. I give up, long waiting and a huge disappointment. When i typed this message, VPN got off two times, but resumed again. VPN going off while watching US Netflix if really annoying. Online games like Clash of Clans and Plunder pirates drops connection every time VPN goes off. I never had these problems with iOS7 and older Freedome. Also the multi-profile when I could switch to different country directly from iPad setup was great. Why did you have to downgrade off that great feature? I really don't understand what's going on, what has happened to old fashion testing and listening to the customers opinion?

    Regards,

    Muumipappa
  • HofresHofres Posts: 5
    Same here. Problem persists on both my advices, iPad and iPhone. Before in the days, everything was better...
  • RelexRelex Posts: 12
    I experience exactly the same problems on my device; Iphone 5 running on IOS 8.0.2 .
    The problems started after installing IOS 8 and the FREEDOME updates that followed.
    The fixes including the last version 2.0.4 did not resolve this.
    Because of the problems descibed above I did not update FREEDOME on my I pad after downloading IOS 8.
    I luckily still run the old FREEDOME version here on IOS 8.0.2 . without having any of these problems.
    In my opinion, the best option to suggest is downgrading FREEDOME to the old version untill 2.0.5 can be launched after being tested to be absolutely error proof.
    underthewhip
  • HofresHofres Posts: 5

    *Update* after testing the newest version on both my devices (iPhone 5c and iPad Air wit iOS 8 running) for some hours: Before updating to 2.0.4., I deleted the Freedome app as well as the existing VPN profile and rebooted my devices. Hitting the "on" button in Freedome, the VPN profile was installed and Freedome was working, pushing a message "Freedome is now working on iOS 8" or something like that. Until now, it is running smoothely on both my devices. I will reply again after a few days and see how the app is working.

  • BenBen Posts: 2,641 F-Secure Product Expert

    Please find more information on the remaining issues in 2.0.4 in the following Knowledge Base article.

    http://community.f-secure.com/t5/F-Secure/Freedome-VPN-connection-problems/ta-p/61195

  • Hi,

    "While this concerns only a very small portion of our users we understand that is an extremely unfortunate situation to those who do encounter it. "

     

    Could you please describe what kind of configuration does work? We see reports that the problem still excists on iPhone, iPad and iPod Touch with iOS8.0.2

     

    What combination of hardware and iOS is working so that the VPN connection is never turned off unless it's manually turned off in the Freedome client?

     

    I try to get a working configuration somewhere and verify different functionality side by side.

     

    Regards,

     

    Muumipappa

  • I think I was able to get it working:
    Remove the freedome profile
    Uninstall Freedome
    Reboot
    Install Freedome 2.0.4
    Install profile

    The VPN has been up for 15 minutes. Previously it disappeared within a minute.

    You need to remove the VPN profile before you uninstall the program.
  • MihoMiho Posts: 16

    I am not sure if this input helps F-Secure team and other users, but anyway I am describing what I have been experiencing after the 2.0.4  update.

     

    Environment:

    iPad Air with iOS 8.0.2

    Freedome VPN 2.0.4

     

    I have done all the deleting and re-installing procedure as described & suggested by F-Secure team.

     

    Symptoms:

    1. Every time I change the virtual location, the app asks to install profile (went back to old feature?)
    2. VPN stays as long as I do not turn it off manually; however, Wi-Fi connection is disturbed frequently. I do not know this issue is the combination of Freedome and iOS or iOS still has the Wi-Fi connection issue?
    3. Once I turn off Freedome VPN and then try to turn it on manually the error “Error initiating VPN connection” happens (see the attached screen shot). VPN.jpg
    4. When I got this message, I need to re-boot the device and I must turn on Freedome VPN manually and again must install the profile.
    5. Also every time I turn the device off and then turn it on, I must turn Freedome VPN on manually. It does not start automatically.

    Just a quick feedback...

  • Hi,
    Quick update what I encountered with Freedome during the weekend. First of all the new version 2.0.4 is not working very well. On my iPod touch, Freedome stopped working completely and I just removed the VPN profile and also removed Freedome. Will not install again until new version of Freedome and/or new iOS 8.1 will launch. My iPod could not connect to any location anymore, actually it tried to connect to Finland location whatever location I chose but could not finish the connection, just tried and tried but no success. No error message also whatsoever.

    Ipad works a little better. Location can be changed and I could even watch some US and Canada Netflix, but only with Apple TV airplay, straight from iPad it's impossible. VPN connection stays open so I can launch the movie and start airplaying it from my iPad and sometimes even have time to put the subtitles on. This is the first difficult job for Freedome. The VPN often gets disconnected when I change the subtitles. Anyway AppleTV seem to stream US and Canada films straight from the servers and not through iPad, so it's not necessary to have the active VPN connection on during the film, actually I can put the iPad to sleep during the film with no interruption. After the film VPN connection is lost and I have to establish it again manually, so it really does not stay on by itself!

    My biggest worry now is the security. I think that many people use Freedome for extra security and not just to watch US netflix etc. When the VPN connection drops off (and it drops off very often and very easy) the web connection stays on normally, but with no active VPN connection. So when I usee free WiFi and the VPN drops off I guess I'm not very secure?

    Regards,
    Muumipappa
  • I am now trying the fix that was suggested in the KB page. The immediate change that I notice is that the VPN reconnects when I open a browser window or an application. This is a huge improvement from before.

    Remains to see what happens from now on. I am on iOS 8.0.2 and using iPhone 5c.

    Another thing. Why is the VPN-profile not signed?
  • MihoMiho Posts: 16
    Hi
    Just received Freedome VPN 2.0.5 update. VPN connection has been good and not dropping so far Smiley Happy
    Thank you for the fix!
This discussion has been closed.