Online safety 2.107.2552 and Firefox

I'd like to report a possible bug. The new version of online safety does not show website ratings when secure searches (https) are performed in Firefox. For example, the website rating icons are missing when I perform a google search (google forces https on all searches). However, the ratings do appear when I perform an unsecured (http) search (like Bing searches). IE is not affected by this problem.

Best Answer

  • BigPeteBigPete Posts: 42
    Accepted Answer

    Update:

     

    I resolved the problem by performing a fresh install of F-secure.

Comments

  • SimonSimon Posts: 2,587

    Hi BigPete,

     

    Could your issue be related to this one, I wonder:

     

    http://community.f-secure.com/t5/Security/Latest-Firefox-version-and/m-p/51861#M9377

     

    Further, it seems that an upgrade yesterday to Online Safety and Safe Search provided some fixes for Firefox issues.  Have you tried reinstalling the Browser Extension in Online Safety > Settings?

  • NikKNikK Posts: 931

    I have the same version and FF 29.0.1 and the rating icons are there, even with Google HTTPS. But if you don't allow javascript they won't show. For example if you have the add-on NoScript installed you have to allow google for the ratings to show.

  • BigPeteBigPete Posts: 42
    I don't have No Script, so that isn't the issue. I've noticed the problem in both 32-bit Windows 7 and 64-bit Windows 8.1. The problem exists on both FF 29.0.1 and ESR 24.5.0. Website blocking works but the rating icons are not there. The problem arose after the update to Online Safety version 2.107.2552. I assume this update was to fix the Windows XP problem, which I previously reported about.
  • BigPeteBigPete Posts: 42

    To add to my original post:

     

    I've verified the problem on two computers. One computer runs Windows 7 SP1 32-bit, and the other runs Windows 8.1. The problem exists for FF 29.0.1 and FF ESR 24.5.0. IE 11 is not affected. I have not checked my XP computer yet.

     

    I don't have No Script.

     

    The problem began after the recent update to Online Safety (ver 2.107.2552). I assume this update was a fix for the XP incompatibility discussed in other threads.

This discussion has been closed.