iTunes can't see any of my devices since install Internet Security 2014


Ever since I installed Internet Security 2014, two weeks ago, iTunes has been unable to see my iPad, iPhone or iPod. 


It does connect to the internet without any problems and the devices are visible as drives on my computer, so it's not an internet connectivity issue or a dodgy cable.

I had similar problems with Mozy's home backup software but that was solved by reinstalling the Mozy client.  Reinstalling iTunes has made no difference though.  All the expected local Windows services are running, so I'm out of ideas.

Can anyone help?


  • NikK
    NikK Posts: 903 Forum Champion

    Have you tried temporarily turning off all security features just to see if that helps? Launch F-Secure, click Computer Security, select the Tools tab and click "Turn off all security features"


    If that doesn't work it's more likely related to the Apple USB Driver. Try following these instructions and see if that helps:

    Give Kudos to say "thanks". Click "Accept as Solution" to inform others when your issue's been solved
    Need more help? Submit a Support Request or chat / call F-Secure support
  • incandescent
    incandescent Posts: 3 Observer

    Hmm, still no joy.  iTunes definitely stopped working immediately after installing F-Secure, but disabling it temporarily doesn't fix the problem.

    I'll have to try uninstalling F-Secure to see if it's really the culprit.

  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hi incandescent!


    Doesn't sound like an issue we typically encounter, so please let us know if the uninstall/re-install helps out, otherwise I'll go ahead and escalate this for you Smiley Wink


    // Chrissy

This discussion has been closed.
Pricing & Product Info