FS not installing



I am trying to install F secure Internet security, but it's not working!  Yesterday, I installed the software with no problem, but there was a conflict with an expired version of AVG anti virus.  Because F Secure kept trying to remove this without success, the only way I could find to manually uninstall AVG was to uninstall FS and then uninstall AVG.


I am now trying to reinstall FS, I go to download, click install, select I agree to terms and conditions.  I then see the  "Preparing for installation" box and a progress bar for installing F secure.  Once the progress bar reaches 100%, the box closes and nothing else happens.  If I click on download and install again, I receive a message syaing that installation is already running.


Even if I leave it for hours, the installation does not complete, nothing happens after the first progress bar reaches 100%.


I am running Windows vista home basic.


Can someone please advise me as to what I should do to complete the instllation?




  • Assuming you have tried System restore, you may have to make sure that you have removed any remnants of both AVG and F-Secure.


    You can try this tool to help you with this;  https://www.dropbox.com/s/o0kjx6drcxj8mc6/Antivirus%20Remover.exe?m





  • Fendy
    Fendy Posts: 67

    Hi Vholme,


    Make sure your Vista is using SP2. You can also try to use workaround by Simon and Blackcat above.


    If the issue still persists, please open a support ticket with us. You can submit your support request from following address:


    To provide better information to our support, also send FSDIAG with your support request as instructed here:


    Best regards,

  • Hi everyone,


    Thanks to all of you for taking the time to offer me solutions.  The solution from Simon worked perfectly and I now have a working version of F secure on my computer!  I will keep a copy of the uninstall just in case as I don't think I'd know where to find it again!!


    Thanks again Smiley Very Happy



  • Simon
    Simon Posts: 2,674 Superuser
    Glad to have helped, Vikki. :)
  • Chrissy
    Chrissy Posts: 438

    Simon & Vholme,


    Thanks for your input, and sorry you had any trouble finding the F-Secure Uninstall Tool - I've actually had difficulty finding it myself!  Based on this feedback, we've created a sticky post in the Community so that the location is more visible.  This post is located here:




    Vholme, glad your problem is solved, and welcome to the F-Secure Community!


    // Chrissy

  • Simon
    Simon Posts: 2,674 Superuser
    Thanks Chrissy, that's great. Have a Kudo! :)
  • wrose
    wrose Posts: 4

    I am a Virgin Media Customer and am having to change to F-Secure. The downlad intallation has been stuck at 58% for over an hour now removing Virgin Media Security. WHAT DO I DO?

  • Simon
    Simon Posts: 2,674 Superuser

    Hi, and welcome to the forum.  :)


    I've not encountered Virgin Media Security, but it probably would have been better had you uninstalled that, before starting to install F-Secure.   If you think the installation has truly ground to a halt, and there is no other way to 'escape' it, then all you can do is reboot and start again, but this time, uninstall Virgin Media security before staring the F-Secure installation, and hopefully all will go OK.


    I should point out that there may be a danger of VMS being 'half in, half out', which may prove problematic when you do come to uninstall it.  In that case, you may have to reinstall VMS, in order to uninstall it again, then start the F-Secure installation with a clean slate.

  • Blackcat
    Blackcat Posts: 511

    Overall, here is a trouble shooting page for F-Secure SAFE using Virgin as your ISP; 




    Your initial post was not very clear; the installation of F-Secure is stuck on 58% and during this process you tried to uninstall VMS?


    If so, then as Simon suggested I would try;


    1. Uninstalling F-Secure first. Then reboot.


    2. Then make sure that you have completely uninstalled the previous security program-Virgin Media Security 10; in particular download and run the specific uninstaller, UserCommunity-Uu-RpsUU.exe, listed.


     http://community.virginmedia.com/t5/Internet-security/Virgin-Media-Security-10-FAQ/td-p/910393. Reboot again.


    3. Install F-Secure again. Reboot.


    I believe VMS is based on a stripped down Trend Micro Security. By the comments on the Virgin Forum it was not a popular product and you will find the F-Secure is a lot more stable and will give you better protection. Further, in the SAFE version it will "provides browsing protection and parental controls for up to five devices, such as PCs, laptops, Macs, smartphones or tablets and is available to all our new and existing Virgin Media broadband customers".


    Post back here to let us know whether you solve the problem. 





  • wrose
    wrose Posts: 4

    Dear Simon,


    Many thanks for your reply. I'm afraid I'm not very computer literate so just would not know where to start with your suggestion. After many attempts I did get in 'chat' touch with a technician who somehow used my computer but that finished with the computer closing and re-starting. Since then I have been just waiting foor something to happen but nothing has and each time I try to get in touch again after ten minutes I get the message 'Technician Console has ended the session'.

    As far as I can see both my Virgin Security and the pre-loaded McAfee programs have disappeared from the opening screen which I presume means my computer is now totally unprotected.


    So I have resorted to e-mail and only hope that I get some sort of response eventually.


    Again my thanks for trying to help



  • wrose
    wrose Posts: 4

    Thanks Blackcat,


    I am most grateful for your help and would follow it if I knew what to do. As you will see from my reply to Simon I am not very computer literate. Just push the right button to start it and disconnect the electric supply when any thing goes wrong is my best ability.


    As you will also see I did manage to get in 'chat' touch with a technician but the session seemed to end with my computer closing down and restarting. However, I am not sure what to do next. The icons(?) for Virgin Security and the preloaded MacAfee seem to have disappeared from the screen though.


    Again my thanks,



  • Simon
    Simon Posts: 2,674 Superuser
    Hi. Peter,

    Blackcat's instructions are very clear, if you follow them to the letter. It's just a question of downloading and running the uninstallation file for VMS. The program itself will tell you what to do.

    However, if you think the technician has removed both VMS and Mcafee with Remote Assistance (when he operated your machine), and you are left unprotected, it's probably more important to get some protection installed that worry about anything else, so I would try running the F-Secure installer again, and hopefully this time it will install correctly. I would imagine that the program was struggling to remove both VMS and Mcafee before. For future reference, it's never a good idea to have more than one anti virus program on one machine, as this can lead to problems.

    Do come back to us if you require further help. :)
  • wrose
    wrose Posts: 4

    Dear Simon,


    Once more thank you for taking the time and trouble to try and sort me out.


    Firstly I was in no way trying to belittle the help that Blackcat was suggesting it was more my own abilities. For example the Virgin site to which I was directed talks about 'Supported Platforms', 'System Requirements', etc. All I know is that I have a Toshiba Laptop given to me by the kids so that I can keep in touch with them and as for unistalling, I just would not know where to start. So, as you can see it is my level of knowledge that is the problem here, certainly not the help being offered.


    Anyway, I am very pleased to say that your suggestion of re-installing has been successful and that I am now once again covered and safe from the 'nasties'..


    The funny thing though is that in the process I have used two of my five licences although this will never be a problem


    Many, many thanks for your time and patience both are greatly appreciated,



  • Simon
    Simon Posts: 2,674 Superuser

    Glad to hear you're now protected, Peter.  thumb.gif  Do give us a should if we can be of any further help.


    Incidentally, I think you underestimate yourself.  Uninstalling a program is no more difficult than installing one.  All you do it hit the Start button, go to Control Panel > Programs > Uninstall a Program, then find the program you want to get rid of, and double click it.  The computer will then tell you if you need to do anything else.


    Good luck!


    Simon.  :)

This discussion has been closed.
Pricing & Product Info