Virus database status "Waiting for update" for six days.

Last week, I upgraded 2 out of 3 systems from F-Secure Internet Security (FSIS) 2011/12 to FSIS 2013 (the 3rd will be another thread).  The system descriptions:

    System 1: A low-use Windows XP Professional system, used mainly for e-mail and scanning/printing.  Regularly patched.  Always on and connected.  Installed as logged-in user.
    System 2: A Windows 7 Professional laptop, used as an out-of-office system.  Also regularly patched.  Regularly on (not always) and connected when on.  Installed with "Run as Adminstrator".

    System 3: When I get fshoster32.exe to stop crashing....

Neither system has anything outrageous on it, network connections are "Assume always connected" and "No HTTP Proxy", and both ran FSIS 2011/12 flawlessly.

Also, I'm assuming FSIS Installer Release 4 was used, since it has the same version number as what I downloaded after re-subscribing.

However, since upgrading to FSIS 2013, virus definitions are not updating.  
    1) The "Virus Definitions" field under Database versions (Settings -> Database Versions) has stated " Waiting for update " since upgrade on each system.  
    2) Peforming a " Check for Updates " results in "Update check was successful. Your product is already up to date."
    3) The "Virus and spyware scanning" field under Status alternates between nothing and flagged red with " Out of date ".

The support site knowledge base doesn't seem to have anything useful on this.

Is anyone else having this issue?  Anyone know of a solution? 

Accepted Answer


  • Sneekes
    Sneekes Posts: 2

    Similar story here.


    Have been using FSIS 2013 relatively painless since April (when I had updated from a previous version).


    Today, when prompted I applied a free update to 'Computer Security 12.83 build 100', anti-virus is at 11.00 build 19132


    Since that point (and after several reboots) I am at pretty much the same situation as AVBluz:


      1) The "Virus Definitions" field under Database versions (Settings -> Database Versions) has stated " Waiting for update " since upgrade on each system.  
        2) Peforming a " Check for Updates " results in "Update check was successful. Your product is already up to date."
        3) The "Virus and spyware scanning" field under Status is flagged red with "Out of date".


    The only thing I have found that looks slightly odd to me (and I acknowledge at this point that I'm out of my depth) is that when I look at Common settings > Downloads there are several 'anti-virus sounding' downloads that have a status of "'not installed".


    The top 4 items look like this:


    Received                Title                                                                         Status

    30/07/2013             F-Secure Hydra Update 2013-07-30_05        Not installed

    30/07/2013             F-Secure Aquarius Update 2013-07-30_08   Not installed

    30/07/2013             Computer Security 12.83.100                            Installed

    30/07/2013             CCF Basic 1.83.311                                             Installed


    Maybe that's completely normal?


  • AVBluz
    AVBluz Posts: 8

    Only thing which has downloaded for me is:


                    F-Secure ORSP Engine Update 2013-06-05_01 (version '1370467978')

    Otherwise, it looks like we're running the same thing:



               Computer Security 12.83 build 100

               Anti-Virus 11.00 build 19132
               DeepGuard 4.10 build 275
               E-mail Filtering 1.02 build 14400
               Management Agent 8.30 build 43113
               User Interface 10.00 build 176


    And the Internet Security Suite (FSHoster???) is:


               F-Secure 1.83 build 311

               CCF CUIF 10.01 build 36597
               CCF DAAS2 1.10 build 369
               CCF Automatic Update Agent 1.05 build 1065
               CCF Upstream 2.00 build 118
               CCF Diagnostics 8.00 build 18415
               CCF Scanning 1.23 build 124.8831
               CCF Network 1.02 build 128
               CCF Reputation 1.0 build 25.1877


    Maybe FSIS 2013 Release 4 was released before ready.  I know on my 3rd system, I'm having issues with fshoster32.exe crashing, so I can't even tell if updates are happening.


    3 systems, 2 different operating systems and 4 different network connections (including 2 coffee shops), none working "as advertised".  I've never had this bad of an experience with F-Secure products in the 14-15 years I've used them; I can't remember anything beyond being annoyed at having to reboot until these past few days.

  • makis
    makis Posts: 12

    Similar situation here,also..."waiting for udate"

    It's obvious a bug...but if you perform a quick scan and then select "show report",you will be informed that you have the latest virous definitions!!!

  • Jouni
    Jouni Posts: 135 F-Secure Product Expert



    Regarding this problem, I would suggest you to open a support request and provide an fsdiag:

    To create an fsdiag:

  • makis
    makis Posts: 12


    I do not know how(maybe after last update)but in my case at least,the problem does not exist any more!Everything seems fine nowSmiley Happy

  • AVBluz
    AVBluz Posts: 8

    That's the plan (for tomorrow at least; have to make a living today).  Wanted to see if others had a similar experience first.

  • AVBluz
    AVBluz Posts: 8

    Ran a manual update.  Nothing. 


    Ran a quick scan on two systems.  From the scan reports, current definitions versions:


    Viruses:  2008-03-24_01 (on both.  A five year old definitions db?)

    Spyware: 2013-07-26_01 (the second system had none).

  • Sneekes
    Sneekes Posts: 2

    Turned the PC on this evening and it seems it's fixed.


    Looking again at Common settings > Downloads


    New updates for Aquarius and Hydra were produced, downloaded and successfully installed today, no visible downloads are showing as "not installed"


    'Virus Definitions' now show updated 'Today, 18:05 (2013-07-31_07)





  • AVBluz
    AVBluz Posts: 8

    I've been out of town on business since last week, and just got back last night.


    I'm still having issues with FSIS 2013 not updating on two systems, and will be gathering info to file a support ticket.


    In looking at the fsua results from FSDIAG, updating worked for around 24-28 hours after upgrade on one system, then stopped for no reason.


    A Wireshark session I ran last week before leaving showed connection to f-secure servers, but no downloads, if I recall correctly. I need to rerun to be certain.

  • viktik
    viktik Posts: 62

    I am telling what i know. First time install of  f-secure IS 2013 takes a long time to update. Status will stuck in "waiting for updtae". So I restart the system after 2 hour update with 60 KBps internet speed. If that doesn't solve the problem then go to status and turn OFF then ON the module which is stuck in waiting for update.


    My system also started crashing after i installed the new version. So i installed the new graphics driver and the crash disappered. So try installing new driver for video and audio.


    I hope this may help in solving your problem.

  • Jagadesan
    Jagadesan Posts: 129 Former F-Secure Employee

    Hi AvBluz,


    Kindly get the fsdiag and submit it to the support enginner that you are dealing with so that he can assist you to verify the logs to see if there is any issue with the update polling agent.



    Best Regards,

  • AVBluz
    AVBluz Posts: 8

    I had already opened an SR and submitted fsdiag output.  Support pointed out a bad registry setting, and suggested I use UninstallTool and reinstall.  I'd already done that several times prior to submitting an SR, but the registry comment made me think of doing the search and destroy in the registry. 


  • Jagadesan
    Jagadesan Posts: 129 Former F-Secure Employee

    Hi AVBluz,


    Kindly PM me your SRID so that I can take a look at your case.



    Best Regards,

This discussion has been closed.
Pricing & Product Info