F Secure Internet Daemon has stopped working

Five days ago I downloaded and installed a trial version of the Internet Security suite 2012 on my Win 7 64bit system. 
Everything went fine until this morning when, without my having made any changes to my system, I booted up the machine and there was no sign of the suite.  The launch pad no longer appeared in the taskbar.  I attempted to launch it from the icon on my desktop but nothing happened when I clicked on it.  I then went to services.msc and discovered that all of the services related to F-Secure had been disabled.  I reenabled them and rebooted the computer but though they remained enabled I was still unable to launch the program.  I tried executing fsdfwd.exe directly from the program but all I got was a black DOS screen and the message that the F-Secure Internet Daemon had stopped working.

Since then I have run various anti malware programs including Malwarebytes, Hitman Pro, Spywarebot, and two online scanners but they have all turned up clean.  Even Hijackthis has not shown up anything suspicious.  I will probably have to install a temporary antivirus program as I assume that this machine is no longer protected. Does anyone have any ideas on where to go from here?
Thanks

Accepted Answer

Comments

  • tripodzidtripodzid Posts: 42

    Be sure that you are only running a single AV program and anything of the same software as it may conflict how each software will scan your system for threats.

     

     

    __________________

    Business is the game!! image

  • cyberfishcyberfish Posts: 3

    Thanks for your reply.

    The only one of the antivirus programs that were actually installed on my machine was Spybot and I did a clean uninstall
    on this and rebooted without any result.

  • JaysonJayson Posts: 595

    Hi cyberfish,

    Please reinstall the F-Secure Internet Security 2012 as the previous installation might be corrupted.

    Thanks.


    Best Regards,
    Jayson

  • cyberfishcyberfish Posts: 3

    Hi,

    I had already done that just before I checked back with this forum. Should have tried it in the first place as everything seems ok now. The 30 day trial started all over again which surprised me as I thought it would just pick up where it left off.  By the way, when is the 2013 suite due for release?

     

    Thanks to all for your help.

  • JaysonJayson Posts: 595

    Hi cyberfish,

    Glad to hear that your F-Secure program is working well now. ETA for F-Secure Internet Security 2013 release still unconfirmed.

    Thanks.


    Best Regards,
    Jayson

This discussion has been closed.