Browser Protection is making Firefox sluggish

2»

Comments

  • Jhumur-

     

    A few days ago, I opened a support case with F-Secure. I told them that others are having the same problem (I mentioned these threads). When I hear back from them, I'll post the results.

  • I'm interested in the response as well. Until then, I will keep the BPT "on" to provide whatever protection it can offer. I'd rather be a bit sluggish than unprotected.

  • Hello all,

     

    For further investigational purposes: is it possible to check whether disabling exploit shield or web site ratings have any effect on the issue?

     

    (F-Secure -> Settings -> Internet -> uncheck "Web site contains an exploit" and both checkboxes under "Show ratings for:")


  • @Siltanen wrote:

    Hello all,

     

    For further investigational purposes: is it possible to check whether disabling exploit shield or web site ratings have any effect on the issue?

     

    (F-Secure -> Settings -> Internet -> uncheck "Web site contains an exploit" and both checkboxes under "Show ratings for:")


     

    - I tried unchecking both options under "Show Ratings For": Freezing still occurred. Then, I tried with everything checked except for "Website contains an exploit ": Freezing still occurred. Finally, I tried with everything checked except for "Web site rated harmful": Freezing still occurred. 



  • - I tried unchecking both options under "Show Ratings For": Freezing still occurred. Then, I tried with everything checked except for "Website contains an exploit ": Freezing still occurred. Finally, I tried with everything checked except for "Web site rated harmful": Freezing still occurred. 


    Thanks for testing this one out! I'm still interested in hearing if it's the same for everybody else experiencing the issue?

  • yesterday

    @Siltanen wrote:

    Hello all,

     

    For further investigational purposes: is it possible to check whether disabling exploit shield or web site ratings have any effect on the issue?

     

    (F-Secure -> Settings -> Internet -> uncheck "Web site contains an exploit" and both checkboxes under "Show ratings for:")

     

    Turning the abovementioned settings didn't make much of improvement. While some pages seemed to load marginally faster, others hung up as before. These were all news webpages from Yahoo!, Guardian, MSNBC, etc.

     

    Earlier, I had taken a previous suggestion and turned off all my other extensions/add-ons. Then I toggled BP on and off, and it confirmed that it's BP that's at the heart of the sluggishness. While turning off the other extensions made FF snappier (again, mariginally) it did not seem to make a significant difference, For a dramatic difference, you have to tun off BP.

     

    P. S. I also took another earlier suggestion, and renamed my FF profile. But, this too didn't help.

  • UPDATE: Opened a support case a few weeks ago, still haven't heard anything. Yesterday (when FF7 was released but BP not updated yet), FF was running fine. Today, now that BP is updated, temporary hanging still occurs when clicking links, opening pages. So, for me at least, this problem is still present.
  • Just a thought: Is there a correlation between the number of links on the page and the behavior of the browser?

  • BigPeteBigPete Posts: 42
    "Just a thought: Is there a correlation between the number of links on the page and the behavior of the browser?" No - temporary hanging happens randomly -- it has happened when loading pages with lots of files/links, and it has happened when loading pages with few files/links.
  • Hi,

     

    I'm representative from R&D.

    We are currently working on this issue at the top most priority now. Please be patience as there are many scenarios mentioned in this thread. We will come back to you with our findings.

     

    Thanks for your report and please continue to update us if you have new findings at your end.

     

     

  • patetpatet Posts: 57

    Are you going to fix the toolbar buttons as well? I.e. them being too big and stretching the whole UI of Firefox etc..

  • jhumurjhumur Posts: 10

    Came back for an update on the issue. Good to know that this is getting some attention. I ennded up uninstalling F-Secure, and going with a competitor's product for which I had received a trial license. I still hope to go back to F-Secure since, while it worked properly, it was one I liked the most out of three I had tried.

  • Hi,

     

    About the button size issue that you mentioned. Could you send me your screenshot and steps to reproduce?

    I suspect it is separate issue.

  • hewtachewtac Posts: 26

    Hello all,

    For those who are not aware, the performance issue with Firefox and Internet Security 2011 has been resolved, and has been released via automatic update "F-Secure Browsing Protection SW Update 2011-11-04_01". We are also working round the clock to address a similar issue in Internet Security 2012; we will promptly post a reply when we have an update.

    Sincere apologies for the delayed notification.

  • hewtachewtac Posts: 26

    Hello again,

     

    Just to inform our users that the fix for Internet Security 2012 was released at approximately 14:25 UTC. The fix is distributed automatically, you will simply be prompted to reboot when the fix is made available to you. To check if you have the fix:

     

    Click on the F-Secure tray icon (bottom-right corner of your desktop). Right-click on "Online Safety" and select "About". Version number of fixed component will be 1.45 build 21835.

  • HexoHexo Posts: 240

    Hey,

    could it be possible, that the Browser Protection of F-Secure 2012 responsible for slower loading of webpages is?

    I notice that many web pages will load slower than usual

  • hewtachewtac Posts: 26

    Hi Hexo,

     

    Would appreciate that you open a support request with our team directly: www.f-secure.com/support, we can go through the troubleshooting steps to identify your issues. If you already have one, please give us the SR-ID so we can track the status of your ticket. Thanks in advance.

  • gadget_sagadget_sa Posts: 1

    Sorry to open an aold wound.... 

    Are people still having issues?

     

    I have been slamming TalkTalk about a really slow connection on Fibre (less than 2mb) and all the while its Firefox and TalkTalk Security (F-Secure)

     

    If I "unload" the security then FF runs a test at +24mb, but with security in place its less than 2mb.

     

    Have tested in Safemode, have created new profiles - neither has any impact. 

     

    Chrome tests at +24mb with security in place or not. 

     

    Anyone else?

  • celaveycelavey Posts: 40

    This issue has already been resolved, though I am not sure if you will get this type of problem every time Firefox will update itself to its latest version, F-Secure should also update. image

  • patetpatet Posts: 57

    I've seen similar reports.

     

    Yes, the Browsing Protection addon is still causing massive performance problems.

     

    Hope they will sort this out with 2013 as they move into the new approach with no browser addons.

     

    Until then, you can disable browsing protection if youd rather have performance over security

This discussion has been closed.