Import CSV-Datei

JochenWi
JochenWi Posts: 4 New Member

Um die Passwörter von Kaspersky hierhin zu übertragen habe ich den Angaben zufolge eine Excel-Datei erstellt, die Spalten mit den vorgeschrieben Überschriften ausgefüllt und die Datei dann im CSV- Format gespeichert. Wenn ich dann unter Einstellungen - Passwörter importieren - KeePassX V 2 die Datei importieren möchte, kommt der Hinweis „Ungültiges Dateiformat“. Woran kann das liegen?

Google-Übersetzung:

According to the information, in order to transfer the passwords from Kaspersky here, I created an Excel file, filled in the columns with the prescribed headings and then saved the file in CSV format. If I then want to import the file under Settings - Import passwords - KeePassX V 2, the message "Invalid file format" appears. What can be the reason?

Accepted Answer

Answers

  • Firmy
    Firmy Posts: 111 Moderator

    Hi @JochenWi

    Welcome to our community page. Thank you for your post.

    May I confirm with you that you have followed the instructions from this link? 

    https://community.f-secure.com/id-protection-en/kb/articles/9269-how-to-transfer-password-entries-from-kaspersky-to-id-protection

    And kindly make sure you choose "comma delimited" when save as or export the file to csv.

    Kindly let me know if this helps.

    Thank you and stay safe.

  • JochenWi
    JochenWi Posts: 4 New Member

    Hi @Firmy

    Yes, I have followed this instructions and chosen „Trennzeichen-getrennt.CSV“. This is the german appellation. But the translation from „comma“ in german is „Komma“. This doesn’t exist. „Trennzeichen“ are „delimiter“. It doesn't work. Do I have to pay attention to something with the CSV file? The file type of the CSV file is "Microsoft Excel CSV file. Is this possible via Excel or do you need an extra app for the spreadsheet?

  • Firmy
    Firmy Posts: 111 Moderator

    Hi @JochenWi

    Thank you for your reply.

    The option to save as CSV (Comma delimited) (*. csv) format can be found in Export or when you clicked on Save as. Kindly make sure you choose either of this option.

    You do not require an extra apps for the spreadsheet. If after you have chosen this file format and it is showing invalid file format, kindly make sure you have followed the correct format as described in the community page https://community.f-secure.com/id-protection-en/kb/articles/9269-how-to-transfer-password-entries-from-kaspersky-to-id-protection

    You may also create a trial file by at least putting 2 entries in the Excel file and export the file to CSV format, and import it to ID PROTECTION to test the file.

    Thank you and stay safe.

    JaimsAmirul
  • JochenWi
    JochenWi Posts: 4 New Member

    @Firmy

    Here I have made a decisive step forward. The problem is that there is a difference between the English and German versions of Excel. Third versions could also correspond to the German one. The reason for this difference could be the spelling of the numbers. So the corresponding German way for the English spelling €1,000.00 is: 1.000,00 €. Therefore, in the German version, not the comma, but the semicolon is stored as a separator. Here's the problem. Creating and editing a macro can fix this. This can be seen on YouTube "Excel Macro für den CSV-Export". If you import this file, where the comma is selected as the separator, the message "Added entries 1" appears.

    However, I cannot see where these entries can be found. This did not add any passwords to the vault.

  • KxNoxUta
    KxNoxUta Posts: 1 New Member

    I got it to work.


    • I got my CSV File
    • I got an CSV Editor (actually an XML Editor this time. Just pick sth. free from the internet.) It seperated everything into neat columns for me.
    • I opened it in my Excel (Free "LibreOffice" can probably do it, too??).
    • I added an empty group column and edited the titles as here in the instruction.
    • I saved it as CSV but indeed my German version saves it with ; not , as seperators.
    • I opened the CSV file in my Windows (text) Editor tool. I auto-replaced all ; with , and hit save.



    And it finally worked. But I'm not sure if I want to use it. Which is a little sad.

    • It kind of doesn't seem to offer ways to add new entries from my firefox browser like KeePass
    • The List is a mess. Huge letters showing little of the entry. KeePass shows a chart with all data. If I could pick that, hat would help.
    • It doesn't seem to recognize log-ins like Discord to auto fill, I cannot prompt it with context menu
    • It doesn't seem to help with detecting double entries
    • And then I can switch to your program by importing CSV from others. But I cannot switch back by exporting the same format? Because it only exports *fsk and I would need yet another sth. to switch? That's .... not so user friendly. :'D

    But I guess I'll try some more.

Pricing & Product Info