Process "F-Secure Freedome UI" (Freedome.exe) still running after turning Freedome off

PerAndersPerAnders Posts: 2 New Member

I noticed that the process "F-Secure Freedome UI" (Freedome.exe) used 5-7% CPU. I don't use Freedome so I turned it off from its icon in the system tray and it disappeared from there.

However, that process is still there, making my CPU busy. How do I turn it off completely?

I use Freedome from time to time so I don't want to remove it entirely from my computer.

Thanks,

Anders.

Accepted Answer

  • JaimsJaims Posts: 575 Moderator
    Accepted Answer

    Hi @PerAnders

    From your F-Secure Freedome VPN settings, you can disable the option "Freedome starts automatically when you restart your computer".

    I tried to reproduced this issue but with the above option turned off and I did not see "F-Secure Freedome UI" running on my Wins 10 processes.

    Open Freedome, go to Settings and turn off that option. Restart PC and see if this helps.

Answers

  • PerAndersPerAnders Posts: 2 New Member

    Thanks for trying to reproduce the error.

    But the fact is, it was all my fault - not Freedome.

    I had just installed my new computer, doing all the setup on an administrator account. Then I created and switch to a standard account. The following days I only used the standard account (of course) but didn't realize that the adm account was still logged on and running and on that adm account, Freedome had put up a "welcome" box and that was the one running Freedome UI.

    When I closed that one, no more mysterious Freedome app running!

    So, thanks, but I was all my fault.

    I did also find that disable option inside Freedome.

Sign In or Register to comment.