Freedome won't connect

ParhamParham Posts: 109 Enthusiast



so Freedome won't connect on my windows 10, i click on connect and it remain "connecting"

and i get disconnect, by disconnect i mean well it's like i have no internet, broken or something like that. 

when i stop that connecting, net get back to normal.



Accepted Answer


  • SethuSethu Posts: 720 F-Secure Employee

    Hello @Parham


    May I know the version of your F-secure freedome? have you tried to uninstall and re-install the Freedome?


    If yes, but the issue still remain, could you pelase try enabling the Kill Switch feature?  On Windows, the killswitch feature is turned OFF by default.


    Open Freedome > Select Settings >Tick to turn "use automatic killswitch to cut off internet connection if the VPN connection is disrupted" ON


    You can then restart your machine and check again. If issue not resolved, please provide us some more details:


    How long you are facing the issue?

    Have you try connecting your machine with different network?

  • ParhamParham Posts: 109 Enthusiast
    Hi there @Sethu

    2.26.5768.0 is the version i'm using

    yes i've enabled it and restarted, not working yet.

    well i installed the freedome on my iphone nad laptop, it's not working on my laptop but it works on my iphone, their network is the same tho. but i did test it with other networks too. same result.

  • SethuSethu Posts: 720 F-Secure Employee

    Hello @Parham


    Could you also try the following steps mentioned below? let's see if that helps to fix the issue. 

    1. Clean browsers history and cookies on your devices.
    2. Try to reset the DNS cache on your devices.

    For windows OSOpen command prompt as an administrator and type the following commands one by one:


    ipconfig /flushdns
    netsh winsock reset
    netsh int ipv6 reset
    netcfg -d


    You can now re-start and check agian. 


    In addition, I would also ensure that you have already configured port forwarding range as per this article

    on your home network.

  • ParhamParham Posts: 109 Enthusiast

    dear @Sethu i don't know how to do the third part about that port forwarding, can you please explain where i can do that?


  • SethuSethu Posts: 720 F-Secure Employee

    Hello @Parham


    Thank you for your continued co-operation, you need to configure port range on your router. Please consult your router documentation and follow the specific instructions for your router. Or you can just google it the model of router i.e how to configure port forwarding D-link ,or you can contact the router manufature comapany.



  • ParhamParham Posts: 109 Enthusiast

    Thanks for the response
    i did the part 1 and 2,
    and here is what i did for that port forwarding too, ( got the LAN ip address from ipconfig commend using cmd )



    yet it won't connect, stay on connecting...

  • SethuSethu Posts: 720 F-Secure Employee

    Hello @Parham


    We have received similar cases where we found that Intel network adapter teaming feature enabled which confuses our IP address resolution code as it ignores virtual interface which this creates.


    Our Freedome team has now prepared a fix  with new version 2.27.  You can download the latest version here and  try re-installing the Freedome on your machine. Let's see if that help to solve the issue.

  • ParhamParham Posts: 109 Enthusiast



    it is the same too, there is no way to get a log or something to see what exactly is preventing the connection for freedome? 


  • SethuSethu Posts: 720 F-Secure Employee

    Hello @Parham 


    Yes, its possible to collect the logfiles to analyse and since you have performed all the basic steps for the issue. So you can now contact our F-secure support for futher inverstigation. 

  • Is there a reason the latest version of F-secure isn't pushing out version 27? I can't get access to the login link since it looks like you are pointing to a sharepoint site...

This discussion has been closed.