Freedome blocks images in e-mail ?

When I receive emails from e.g. Ibood, I only get to see the text and no images.
When I turn Freedome off I get to see it.
How can I make sure that I don't have to turn Freedome off every time to view mails with images?
Program is Outlook 2016.


  • Sethu
    Sethu Posts: 724 Moderator

    Hello @Karine01


    Thank you for reporting us the issue, may I know the version of your Freedome? could you please try disable the browsing protection feature and check again?


    And please provide us the name of your email service company i.e, Which help us to further check with relevant team.

  • Version 2.10.4980.0

    Disable the browsing protection feature make no difference.

  • TifaOng
    TifaOng Posts: 32 Former F-Secure Employee

    Hi Karine01,


    Currently the version is 2.23.5653.0. Most likely it was outdated.


    Please remove and re-install Freedome and test again.

This discussion has been closed.

📢F-Secure Quiz Challenge📢

Join our online quiz session on June 15th, 2023, at 11:00 AM EEST and stand a chance to win prizes.

Product & Pricing Info