F-secure is acting abnormal

For the last couple of days, I am finding that F-secure has been bogging down my PC and giving me grief.  I first noticed it when I downloaded a few patches for The witcher.  After downloading these patches, F-secure would make the folder, where I had downloaded these patches in, unresponsive.  It would take up half of my CPU(50%) and computer would get laggy.  My solution was to disconnect from the internet and shut off F-secure.  Everything went back to normal.  After I installed the patches I turned F-secure back on.  That's when I discovered I could no longer access the internet.  I had a connection but I couldn't get firfox to run or windowslive or any other app for that matter.  I reset my PC and everything was back as it should.  Anyway, I start up the witcher and nothing happens.  Hmmm.  I look in task manager and find that the exe. Is running.  I attempt to close it and nothing happens.  So I restart my PC and and again disconnect from the internet and shut down f-secure. I run witcher and it runs.  Yesterday I installed Battle for middle earth and when I attempt to play it, again it won't run.  I don't get a warning or a permission from F-secure asking if its OK to run this prog.  To fix this problem I went int F-secure settings/virus and spyware scanner and changed the option from always ask me, to, if unclear, ask me.  I changed deep guard to the same and now BFME runs fine, like it should.  I haven't had to change anything in fissure since i installed it.  I almost always got a permission when I ran a program for the first time but for the last few days it doesn't even ask if the newly installed programs are allowed internet access.  I run Windowsxp service pack 3 on a p4 3.0 with 4gigs 3200ram.  I am hoping that there is a simple solution because I use my pc at least 4 hours per day.  Any thoughts or suggestions would be very appreciative.


  • MJ-perComp
    MJ-perComp Posts: 432 Superuser


    first of all: what F-Secure are you using?


    What process is eating 50%


    then turn off one module after the other to identify the problem.

    Clear Application Control and DeepGuard.


    What else did you change? Windows Updates, Drivers, ...


    There are many things to continue with but lets start here.

  • capanda
    capanda Posts: 5

    I am using Shaw Secure.  The process was fssm32.exe.  I tried running the Witcher after setting the virus and deepguard back to where I had it(always ask me) and It is running like it should now, although it still has yet to ask if it is allowed to access the internet.  I haven't updayed my drivers in a bout a month and windows did an update about  a week ago.  update for xp security, malicious tool and something else.  I will keep an eye on things and see how things go.  Another problem that has come up is the virus scanner.  I went to full system scan and it scans one file and completes.  I scanned the cSmiley Sadonly drive i got) and it scans 46 files and then completes. virus and spyware scans one file and completes.  This is starting to worry me.

  • MJ-perComp
    MJ-perComp Posts: 432 Superuser

    The team will contact you, I think the problem is already fixed, but not sure. Please hold til tomorrow.


  • capanda
    capanda Posts: 5

    Ok. Ill wait till tomorrow. In the meantime, I am doing a full system scan with F-Secure online.  Thanks for the help.

  • capanda
    capanda Posts: 5

    Ok. I'll try to explain this as best I can.  I have been farting around all day with various scanners and playing around with the internet settings and no luck.  Finally, though, I discovered what the problem with my internet not working.  Any program I run that is not in the F-Secure application control list that uses an internet connection will kill my internet connection.  It seems that the fsecure application control pop up does not come up when I run any of these programs.  I ran a program that required a connection and could not connect.  I minimized that program and attempted to run firefox which also would not connect.  Anyway,  I opened F-Secure and turned off application control in the internet connection options and Bam, programs connect and firefox works. So its now safe to say that there is a problem with application control.  I would imagine that i will have to reinstall F-Secure and hope that this fixes the problem.  I am, however,  still very concerned about the virus scanner.  I ran the Online F-Secure scanner today and was happy to report that my system is free of malware but to be safe i decided to install and run avira to see if I got a bigger problem and sure enough avira found a few hidden objects and a couple of viruses.  Both F-secure and malaware missed them. anyway, is there a way to attempt a repair or do I need to do a clean install of F-secure?

  • Stephan
    Stephan Posts: 340 Influencer

    Hi Capanda,


    First, please uninstall the 2nd virus scanner. 2 AV programs usually create a lot of problems.


    Second, do you have the scan report from Avira? I've seen other AVs sometimes detecting parts of our signature databases as viruses, so it might very well be a false alarm.


    About the initial problem: It indeed sounds a bit odd.

    We'd have to dig into some logs and check the settings as well, but the first and easiest step would be to uninstall and reinstall the security client and then see how it behaves in default settings.


    Could you give that a shot?

    Best regards,


  • capanda
    capanda Posts: 5

    Good morning, Stephan

    I will reinstall this morning and see how it goes.  Avira picked up three that i believe were quarantined by F-Secure. The fourth was in a system restore and the fifth was in Sun/Java.  I am sure Avira saved a copy of the report somewhere and I can send it if you want.  I will return with an update.  Thanks for the help.

This discussion has been closed.
Pricing & Product Info