Freedome startup time has increased

Sometime in the last month or so I've noticed that Freedome has begun to take much longer to launch and attach to the VPN server location.  It used to take about 10 seconds to launch and attach.  Now it takes about a minute.  Once it's attached, performances is the same as before.  Nothing in my system configuration has changed.  MacOS High Sierra.  Same ISP, etc.


Has Freedome added some extra steps to startup?



  • LakshLaksh Posts: 4,444 Community Manager

    Hi ThisPerson,


    Could we know what is the version of Freedome installed on your device?


    Have you tried to connect to a different location and does it happen with anyother location as well?

  • Hi,

    The version is 2.16.5289.0.  I tried a restart with a different location.  Normally I'm US West Coast, so I tried Vancouver instead.  It made no difference.  I still get substantial lag in startup.

  • LakshLaksh Posts: 4,444 Community Manager

    Hi ThisPerson,


    Thanks for the update. I would recommend to get in touch with our support team here via chat or phone so that they can troubleshoot further.


  • I found a solution, but I'm still puzzling over it.  I work in profressional audio and have a sound system based on Dante (Audio over IP).  All Dante devices are fully compliant with regular ethernet protocols and were assigned IP addresses just like anything else on my network (which has a couple dozen devices).  But for reasons that I don't understand, this was the cause of the slowdown.  I moved my Dante devices to a different network, using my Mac's second network port.  The problem went away, but I don't know why.

This discussion has been closed.