Any progress for BP compatibility with Firefox 10?

13»

Comments

  • FS_UserFS_User Posts: 4

    Still it doesn't get updated with FF10.0.2 and Internet Security 2012...

     

  • BigPeteBigPete Posts: 42

    POSSIBLE SOLUTION:

     

    If browser protection not yet updated in Internet Security 2012, take following steps:

     

    (1) Double-click on F-secure icon in task tray

     

    (2) Click "Online Safety"

     

    (3) Click "Tasks"

     

    (4) Click "Check for Updates"

     

    This is the ONLY WAY I could get the BP update & the Service Release Update. It would not download automatically.

  • celaveycelavey Posts: 40

    I think there is a Firefox 11 coming out. Do you think we still get the same problem with version 10?image

  • JaniashviliJaniashvili Posts: 469

    I guess it will have same problem

  • hewtachewtac Posts: 26

    Hi all,

     

    We're aware that FF11 RTM is on 13th March, and we still hope to deliver Browsing Protection support within 2 weeks after FF11's release. This ETA has not changed for each FF release, although we're fully aware that we missed the deadline for FF10, and we truly regret the inconveniences caused.

  • MJ-perCompMJ-perComp Posts: 1,098

    Needless to say that that is too late?!

    Ca you please have an updater that will install the beat without the need to install all the other betas as well!

     

    Thanks.

  • hewtachewtac Posts: 26

    Hello all,

     

    We're pleased to announce that the latest Browsing Protection updates support both FF10 and FF11b8. Barring any major changes by Mozilla, the same updates should work for FF11 RTM as well (due tomorrow 13th March).

     

    FSIS 2011/AVCS 9.x = F-Secure Browsing Protection SW Update 2012-03-08_01

    FSIS 2012 SR1 = Update was released to all SR1 users 30 mins ago, approximately 0800 hours UTC.

     

    To check if SR1 is installed on your computer:

    1. click on the "F" tray icon.
    2. right-click on the Online Safety icon, click "About".
    3. version should say "Online Safety 1.49 build 30982" (ref screenshot below) .

  • andrzejandrzej Posts: 69

    @hewtac wrote:

    Hello all,

     

    We're pleased to announce that the latest Browsing Protection updates support both FF10 and FF11b8. Barring any major changes by Mozilla, the same updates should work for FF11 RTM as well (due tomorrow 13th March).

     

    FSIS 2011/AVCS 9.x = F-Secure Browsing Protection SW Update 2012-03-08_01

    FSIS 2012 SR1 = Update was released to all SR1 users 30 mins ago, approximately 0800 hours UTC.

     


     


    Just letting you know that in F-Secure Client Security 9.x the About screen shows F-Secure Browsing Protection/SW 1.10 build 5683, when F-Secure Browsing Protection SW Update 2012-03-08_01 is already installed

  • hewtachewtac Posts: 26

    Hi,

     

    This version number is correct; it's based on C:\Program Files\F-Secure\NRS\[email protected]\components\litmus-ff.dll:

    - Browsing Protection in FSIS 2012 looks the same as it was in FSIS 2011 (this is intentional), but their designs are different.

    - Thus it's not possible to compare the  version numbers in FSIS 2012 vs FSIS 2011/AVCS9 as they will always be different.

    - to provide FF support we have to deliver separate updates to 2011 vs 2012 products.

    - FSIS 2012 will never download "F-Secure Browsing Protection SW Update xx-x-x".

     

    This also explains why we were able to deliver FF10 support to FSIS 2011 within a week of its release, but were severely delayed for FSIS 2012. We of course wanted to release all BP fixes simultaneously, but some unexpected bugs crept up in FSIS 2012, thus we had to delay the update until today.

     

    We don't expect much changes from FF11b8 to FF11 RTM, so hopefully today's updates makes it easier for all users.

  • beikerbeiker Posts: 33

    FF11 is already. Gonna go ahead if it will make a difference. Fingers crossed* 

  • hewtachewtac Posts: 26

    Hi beiker,

     

    Since my last post, we don't expect anymore issues with BP support for FF10-11. But if you notice otherwise, let us know, or better still open a support ticket.

This discussion has been closed.