disabling nagging SAFE popup in Chrome

Is it possible somehow to disable the nagging popup from SAFE when I do not wish to install the SAFE plugin for Chrome? It used to be annoying to get the popup every day or every browser restart. But I tried to live with it. Now, after latest updates, the popup keeps coming and coming, there is maybe 1 minute between that it does not come. And it pops up and out by itself constantly.

 

Of course, I found a solution, which is to uninstall SAFE. And so I uninstalled SAFE. Would prefer to be able to use the product I paid for...

 

 

Comments

  • UkkoUkko Posts: 3,016 Superuser

    Hello,

     

    Sorry for my ask.

     

    How it looks? Does it ask for install extension or to enable installed extension?

    Does it not possible to disable/deny prompt (remove extension from Google Chrome)?

     

    I tried to re-check with my system:

     

    -- F-Secure SAFE technology preview/beta was installed under Windows 7 system;

    -- Then I tried to install Google Chrome; It's installed as default browser (not by me?!).

    F-Secure Browsing Protection is added to extensions; I removed F-Secure Browsing Protection extension by Google Chrome settings.

    -- There is not visible popups after such (and before this -> was visible ?! kind of prompt-notification that was installed fresh extension).

     

    Does it with differences about stable F-Secure SAFE? Or your experience about some other plugins?

     

    Thanks!

  • apextapext Posts: 5

    Hi, thanks for trying. I am using Mac and the latest OSX version. The one with the SSH bug that was just patched.

     

    I have full version of SAFE installed, as part of TOTAL package. I have not installed any SAFE extension to Chrome, since I do not wish to have it. I do have it installed in Firefox, which works fine.I use the browsers for different purposes, which is why.

     

    I did think an option could be to install the SAFE extension in Chrome and then disable it. Maybe that would stop the nagging. But I would prefer not to install any more extensions than I have to, and fail to see the need for me to go do gimmicks when a simple checkbox choice in SAFE should do it.

     

    I do have uBlock Origin and Privacy Badger installed as Chrome extension but I do not think that should affect anything since SAFE is just complaining about the missing SAFE extension.

     

     

  • UkkoUkko Posts: 3,016 Superuser

    Hello,

     

    Thanks for your answer and clarification!

     

    So, I'm not sure how it should work with Mac-platform. Except that:

    I did think an option could be to install the SAFE extension in Chrome and then disable it. Maybe that would stop the nagging. But I would prefer not to install any more extensions than I have to, and fail to see the need for me to go do gimmicks when a simple checkbox choice in SAFE should do it.

    sounds as partly reasonable point.

     

     

    Maybe will be good to receive attention from F-Secure Mac team about another potential workaround or designed steps to 'deny' popup (which will be valid for you). Potentially, possible to try boost up situation with direct F-Secure Support Channels (https://www.f-secure.com/en/web/home_global/contact-support).

     

    Thanks!

This discussion has been closed.