macOS High Sierra iCloud Photos issue

With a clean installation of High Sierra, using version 1.20.3671.0 of the Freedome software, I am unable to sync macOS Photos with iCloud. Photos do not download or upload. If I turn Freedome off, syncing works.

 

Other iCloud things, like Contacts and Notes, seem to work fine while connected via Freedome.

 

Is this a known issue?

 

Cheers

Answers

  • LakshLaksh Posts: 4,424

    Hi saltinewolf,

     

    Since the Contacts or Notes syncs fine, could you try to restart your device and retry the sync for the photos with Freedome ON?

     

     

     

  • Oh yes, don't worry I've tried that already.
  • I'll mention, too, that I'm connected to a power source. Also using Freedome on an iPhone 7 with iOS 11 with no issue.

    Perhaps there is a iCloud photos server address I can try and ping? Happy to try out any suggestions.
  • LakshLaksh Posts: 4,424

    Hi saltinewolf,

     

    This might need further investigation from our support team. So, please get in touch with them via chat or phone.

     

  • I've not managed to catch anyone on chat when I've tried. Interested to see if anyone else has the problem,  as more people upgrade.

  • I have seen another internet post elsewhere about this issue. The user seems to be using another popular VPN—unsure if it's against a rule here to mention other company's products, but it's PIA. Not sure how their tech differs from what F-Secure use for Freedome.
  • LakshLaksh Posts: 4,424

    Hi saltinewolf,

     

    I have now escalated this case to our support team for further investigation. One of our agents will get in touch with you via email for further troubleshooting.

     

  • Hey,

     

    I have the exact same problem. I also have MacOS High Sierra and Freedome is the latest version. I had no issues with syncing before HighSierra.

  • I've been forwarded from person to person for a few weeks. Now waiting on a reply from R&D. I'm expecting a progress update by the 28th. Will keep you posted.

     

    edit: not "at the latest" but "Next progress update will be send latest by 28 November."

  • I had an email a few days ago basically saying that they haven't figured it out, and that the problem also seems to affect other VPN products. Should get an update next week. Anyway, good to know it's not just me.

  • I have this problem too.  Apple helped me identify F-Secure VPN as the cause.  F-Secure is inadvertantly blocking.

  • If it is not fixed within a week I will ask for a pro-rated refund and switch to Proton.

  • I've been getting weekly emails from support, mostly saying "nothing to report," but F-Secure are saying it's an Apple issue, and other VPN services are reporting the same problem.

  • chris_chris_ Posts: 12

    Same issue here, just jumping in to get updates. 

     

    This has been going on since Sierra for me, but I never got around to posting about it. I always turn off Freedome before opening Photos. Like other users mentioned, it only affects the Photos app. 

     

    Turning tracking and malware protection off doesn't solve it.

     

    Maybe it's a DNS issue? I sometimes can't access sites like appleworld.today with the VPN on either. 

     

    Looking at my network traffic, the processes that usually update/sync Photos, aren't triggered, they stay "silent". It's as if the Photos app isn't opened at all. With the VPN turned off, all the highlighted processes in the picture below will usually start connections.

     

    Screen Shot 2018-02-13 at 9.05.06 PM.png

  • I've had an update. They say the issue isn't reproduceable for the developers with Freedome, version 2.15.5163.0

     

    Seems like I still have the issue. Same for everyone else?

  • chris_chris_ Posts: 12

    I'm on the latest version now as well and just tried again.

     

    It doesn't work with the VPN on.

     

    Without VPN it works as expected. I'll attach another set of screenshots. These are the connections and processes that were responsible for the Photos sync during the 10 minutes without VPN.

     

  • Thanks for that. I've said the issue remains and pointed out this thread.

  • A couple of weeks ago:

     

    "Developer tested with macOS 10.13.3 (Freedome 2.14.5108.0 and 2.15.5163.0) and it seems to work now. Kindly verify if your macOS is updated and check if that work for you as well?"

     

    I replied that no, it still didn't work.

     

    Yesterday:

     

    "This Photos sync issue is very unique and doesn't seems to work well with VPN for some Mac user. Based on the research done, there some other Mac users facing the same issue with VPN. Best person to assist you on this matter will be Apple support to get resolution and below is the discussion thread.

     

    Reference:

    Photos not syncing in iCloud with a VPN

    https://discussions.apple.com/thread/8147809?start=0&tstart=0

     

    Thank you for highlighting the issue. R&D team is aware and at the moment we do not have any workaround towards this issue."

     

    🤷‍♂️

  • kuiviskuivis Posts: 2

    Hi,

     

    I'm running MBP 15" 2017, High Sierra 10.13.4 and Freedome 2.16.5289.0. Comparing my Photos library in my Mac, iPhone and iCloud, I would say the syncing has not worked since 25th March 2018. Today I noticed the issue and found this thread in 5 minutes. I hope the problem will be solved soon.

     

    Br,

  • kuiviskuivis Posts: 2

    A new version of Freedome arrived yesterday, but did not help in this.

    Today  I had a discussion with Apple support regarding another matter and I told about this problem as well. They invited F-secure tech to contact Apple tech Smiley Happy  Great customer service.

     

    Br,

     

  • Anyone suss anything out in the last few months? Anyone try any other VPNs and not suffer this issue?

  • chris_chris_ Posts: 12

    I don't use Freedome on Mac any longer, switched to TorGuard because of better privacy, speed and protocol options, but the issue is the same. 

    Maybe Mojave will fix this… I don't run the beta, so I can't comment.

  • TrixTrix Posts: 1

    I have exactly the same issue.

     

    Timo

  • Hi saltinewolf,

     

    This issue will be fixed in the Mojave (10.14) version. While Freedome is turned on, iCloud Photos will be able to sync.

This discussion has been closed.