Can't sign in to freedome

Hi,

 

I can't sign in to freedome after installation in windows 10 or android. I have f-secure total subsciption active. It only shows "error 500" after i en ter my credentials. I have tried the reinstallation of freedome that didn't help. What can i do to fix this?

 best regards -Ilkka

Best Answer

Comments

  • UkkoUkko Posts: 3,142 Superuser

    Hello,

     

    Sorry for my ask.

     

    But does it possible to login under My F-Secure Account portal with any of browsers?

    https://my.f-secure.com/login

     

    If possible -> and portal should work for you... sounds as there some certain trouble with application's abilities (since different platforms with your experience trigger "error 500") - maybe you able try to contact F-Secure Support Channel for proper investigation:

     https://www.f-secure.com/en/web/home_global/contact-support (when available);


    Or maybe official response or suggestion from more experienced users comes under your topic (later);

     

    Thanks!

     

    // also - does your Total-subscription from F-Secure directly (or from other providers)?

    Since -> I recently trired fresh Freedome installation and it was with abilities to choose operator/provider of subscription. While -> I have only subscription from F-Secure (Total): I tried to login under some of third party providers with random credentials and it also switched to  'error 500' (probably?!) - even expected some words about "wrong credentials";

  • sihvonsihvon Posts: 2

    Hi Laksh,

     

    Yeah. Now sign in works on each of my devices.

     

    -Ilkka

    Ukko
This discussion has been closed.