Freedome VPN doesn´t connect to internet anymore

Some weeks ago Freedome stopped working and had issues in connecting to internet. when I switch it off, internet connectivity works fine.

 

It seems that there is some issues with host name resolution (DNS server ??)

 

Freedome used to workperfectly on my laptop win7 professional when suddenly this connectivity problem arised. I used freedom to stream video from Finland to Philippines,

 

rebooting the laptop didn´t help.

 

Please support. 

 

Nael

Comments

  • UkkoUkko Posts: 3,184 Superuser

    Hello,

     

    Sorry for my reply.

     

    Just as brief suggestion and try to re-check. Recently there was noted that released fresh build for F-Secure Freedome: https://community.f-secure.com/t5/F-Secure/Last-update-broke-my-computer/m-p/95035/highlight/true#M8536

     

    Do you use latest Freedome for Windows (1.16)? If no - maybe you able try to force update (by related option from UI/tray-menu; or by launch fresh installer from F-Secure website). What if it can be useful for your situation?

     

    If not - just back with reply and maybe there will be proper response from experienced F-Secure Freedome users or from official F-Secure stuff.

     

    Thanks.

     

  • NaelNael Posts: 4

    Hi, 

     

    Thanks for the response.

    Yes , I have the latest verion (today it was updated v.1.16.3641.0)

  • UkkoUkko Posts: 3,184 Superuser

    So, since I also just F-Secure user (and with small experience about Freedome) I able to create some suggestions - but maybe it can be not really useful:

    Spoiler
     --> just as double-check that there missing blocking/preventing by any other security software. With meanings - what if it randomly start blocking Freedome for proper work;
    Or, at least, there was some situations when Firewall (possible with Windows Firewall too) block/prevent proper work for Freedome. Such situation possible to re-check if there have any deny/restrict rules for Freedome (or maybe OpenVPN); If so - maybe you able try to remove/disable such rule and check what will be there with Freedome usage;

     --> not clear -   does there also Freedome not able to connect to server ("location")? Or there possible to connect (as Freedome noted that there is "Turned ON" status), but Internet not reachable? Maybe there also possible try to connect with different locations (most likely you tried it, but anyway);

    --> because it happened randomly - maybe there possible try with reinstallation Freedome;
    But also with such situation (where required investigation) good to contact F-Secure Freedome team. Of course, if there some technical trouble.. but not something as your ISP (as example) start blocking VPN traffic (or other kind of this); 

     But basically there can be two other options:

     

    -> most likely there will be more suggestions (with good proper words), but later (?!); 

     

    -> on current time - maybe you able try to use direct F-Secure Support Channels (chat/phone) https://www.f-secure.com/en/web/home_global/contact-support

    What if it will be available and Support Agent have some knowledge (what if such situation is recent and common trouble for Freedome user's experience);

  • LakshLaksh Posts: 4,442 Community Manager

    Hi Nael,

     

    Are you still having the DNS resolving issue with Freedome even after the latest version update? As mentioned in this post, version 1.16 solves the slow DNS resolving issue.

     

    Did you see the issue before or after the update to the latest version?

  • NaelNael Posts: 4

    Hi,

     

    The latest version is in use and the problem still persists. I chatted with Sethu (F-Secure expert on chat service) and tried for hours but unfortunately no solution. he reinstalled the lated verion but no use. Also the old versions were tried , didn't help.

     

    Still waiting for some resolution if someone can help.

     

    Br,

    Nael

     

  • MonteMonte Posts: 3
    Check this link out Nael Laksh & Ukko I think they me be related - https://community.f-secure.com/t5/F-Secure/Looks-like-Sky-are-blocking-VPN/td-p/92294
    Ukko
  • NaelNael Posts: 4

    The is problem still there, no solution was found yet

     

    Thanks

  • LakshLaksh Posts: 4,442 Community Manager

    Hi Nael,

     

    I have highlighted about this post here in your support case. In order to troubleshoot further, please follow up on the case.

  • ZitroneZitrone Posts: 7

    I have/had a similar case. Freedome always stopped working after 2 or 3 days. I am in contact with support since several weeks and have got a number of proposals how to solve the issue. 

    3 days ago I got the last proposal and so far Freedome works but needs to monitor it a couple of days longer.  I have got a new Freedome Beta version and had to add a Windows registry key with the command prompt (administrator mode).

    Before, when Freedome stopped working (blocking Internet when active) was to open the device manager, go network adapters and deinstall  "Freedome Tab driver". Then turn on Freedome, Freedome emmidiately installs the driver again and is functional again (for a couple of days)

This discussion has been closed.