Safe Search prompt after TP191 upgrade

Ville Posts: 642 F-Secure Employee



Some of the beta users have reported that after TP191 upgrade on Windows client, they have a Safe Search prompt that can't be dismissed. We have investigated this problem and it is a problem only in beta, due to beta configuration. Because of this, there will be no fix in the actual client for this problem. Instead, if you have the prompt, we made a small tool that will remove it.


Just download the tool from here and execute it with the Windows account that has the prompt:



(F-Secure R&D)



F-Secure R&D, Desktop products



  • yeoldfart
    yeoldfart Posts: 556 Superuser

    Thank you

  • EetuT
    EetuT Posts: 2 New Member

    Nope, this tool did not help. My system is win 10 + F-secure Safe 16.5. Common Component Framework 2.76 build 212.



  • Ukko
    Ukko Posts: 3,556 Superuser

    @EetuT wrote:

    Nope, this tool did not help. My system is win 10 + F-secure Safe 16.5. Common Component Framework 2.76 build 212.





    This certain tool work with F-Secure SAFE 17; Potentially -- as designed;

    And 'crashed' with F-Secure SAFE 16.5; Not sure.. if there should be 'crash' (or so);


    You able to re-check this topic:


    Where was some suggestions and some official responses.


    But - can I ask about experience? With your experience such prompt happened and based on what setting (you postponed this prompt previously?! or there is clean installation; or something else?!);


    Also with my own opinion:


    --> even Support explained that "should not be a trouble" (and such situation can be most likely with ISP-builds or other branding-builds); And that such trouble "not known" (some days before);


    --> probably there required something as re-check by F-Secure Team.

    Since it looks  as "popular" trouble.


  • nanonyme
    nanonyme Posts: 145 Path Finder


    Just to clarify what Ukko said above: only the tool will crash if you run it against an older unsupported product. Product itself remains running and security is unaffected. The tool simply will not do anything useful.

  • EetuT
    EetuT Posts: 2 New Member

    Thank you for your fast answers.


    This versio is:

    F-Secure SAFE 16.5

    Common Component Framework 2.76 build 212
    CCF CUIF 10.11 build 134
    CCF DAAS2 1.10 build 646
    CCF Guts2 2.05 build 134
    CCF Upstream 2.02 build 681
    CCF Diagnostics 9.05 build 278
    CCF Scanning 1.73 build 275.1078
    CCF Network 1.04 build 214
    CCF Reputation 2.1 build 1342


    Bought it and downloaded in the begining of this year (via University of Helsinki where I study) - two year lisence. The OS is Win10 Home and I have only one profile in it with the administrator rights. Everything worked fine without any probs till the end of May/the begining of June. Now, everytime I turn on the computer comes this annoying prompt asking if I want to use F-secure Search. It does not matter if I answer yes, no or postbone it: next time I turn on the comp the same prompt pops up again, and actually it comes also after midnight. Before Safe I had in this computer F-Secure Internet Security that I uninstalled before installing the Safe.


    I will try next that tool made for a newer version, let see what happens.


  • Ukko
    Ukko Posts: 3,556 Superuser



    I will try next that tool made for a newer version, let see what happens.

    If I normal understand it -> you already tried this tool (and it was not helpful as you noted); :)


    This topic and tool-suggestion from another topic about this one tool.

    Another suggested topic was about potential meanings around situation; And with some advices from official F-Secure team (as "reinstallation" required OR update to latest F-Secure SAFE 17.num);


    I able to add that with my own experience (F-Secure SAFE 16.5 installation):


    - under my installation there listed certain update "Safe Search 10.0.101" (dated to 14.06.2017 probably);


    Such "update" did clean up under my system about installed Safe Search toolbars (and so);


    With your experience - do you have such string under your installation? It possible to re-check by "rightclick" F-Secure tray-picture and choose "Open common settings" under menu; There will be "Updates"-tab with list;


    If indeed installed such update -> maybe based on something it triggered this "stuck" for Prompt; And if not installed (maybe it required for proper view); Or maybe clean up only for SAFE (but if there was installed IS; or instlled AV/IS -- it not work) - but strange if so;


    My "workaround"-suggestion (which I do not able to try with my own systems) can be like this:


    -- temporary re-change your default browser to another (meanings: choose "another browser" as default browser under system settings);

    and did restart;


    -- if there still stuck and Safe Search prompt; So - it was not useful.

    If it will be with normal view - most likely you able choose your "previous" default browser back.


    My "workaround"-suggestion based on meanings that F-Secure Safe Search Prompt should be about "default browser"; Re-change default browser should re-trigger "Prompt" for fresh browser (if supported);

    So - since there should not be "any prompts" already - maybe it possible to re-sort stuck by this steps.


    All other potential workarounds looks more "unofficial" than useful;


    And except "certain fix" as reinstallation F-Secure SAFE (it will be already about F-Secure SAFE 17 probably) or "getting" upgrade for your current installation.... maybe there can be normal advices and investigation by F-Secure teams. As result - they will suggest something with workdays (officially);


    Also there available direct F-Secure Support channels (as chat/phone): ; but based on my experience and responses from topics about "Safe Search Prompt Stuck" - it can be not helpful step;  


    Sorry for my long reply! Smiley Sad



This discussion has been closed.