Last update broke my computer

Good Morning;

    Yesterday Freedome did an update to my Windows 10 computer.  Now it can take up to 10 seconds for the Resolving Host message to clear on my Chrome browser.  On another W10 computer that hasn't updated, everything is fine.  I uninstalled and reinstalled and that didn't fix it.  I tried a competitors VPN and it also now has the resolving delay.  What have you done to my computer?  Can I reverse the installed changes?  I don't have a lot of time to chase this, I would like a quick fix.


Accepted Answer


  • SpeedWagonSpeedWagon Posts: 7

    Okay, I think I found my quick fix, I reinstalled my original install file from February.  It seems to be back to normal at least for now.

  • MarkuZMarkuZ Posts: 1

    I have a similar problem with the Resolving host after the last update. Any solutions other than reinstalling? I really like Freedome, but now I have to keep it disabled.

  • NäsäviisasNäsäviisas Posts: 780

    Is this problem due to Windows update? Have you checked Windows settings? 


  • SpeedWagonSpeedWagon Posts: 7

    It could be due to an interaction between the last big windows update that was installed last week and the Freedome update.  All I know is that going back to the February version fixed it.

  • LakshLaksh Posts: 4,444 Community Manager

    Hello Everyone,


    If you are still facing this issue, kindly get in touch with our Support team via chat or phone so that this can be troubleshooted further.

  • SpeedWagonSpeedWagon Posts: 7

    Good Evening;

        The install file I downloaded in February is working fine.  I'll try the next version when it comes out.  By the comments above there must be others with the same issue.

  • BB8BB8 Posts: 3

    I also need to go back to an earlier version of Freedome to solve some new issues the recent update caused. I contacted Freedome VPN support and they won't provide a legacy installer.


    Do you have a link for the earlier version you're using?   

  • LakshLaksh Posts: 4,444 Community Manager

    Hi @BB8 and @MarkuZ,


    If you have still not changed the Freedome version, I have sent you a private message regarding this issue to get some information for further troubleshooting.

  • ZadokkZadokk Posts: 3
    Just a note to say that I'm also getting this problem. Almost every site causes a Resolving Host message to appear for a few seconds -- extremely irritating.
  • LakshLaksh Posts: 4,444 Community Manager

    Hi @Zadokk, I have just PMed you. Could you please check that and get back to me?

  • BB8BB8 Posts: 3

    Thanks for the suggestion, however it did not change anything here for me. The error I get in Chrome is still that the DNS address for a site can't be found. This only occurs if my OpenVPN for work is connected and Freedome is active. I've read that a company VPN is not supposed to work if Freedome is on but everything had worked well together in the last version. If you have access to the last version installer of Freedome may I have the link? 

  • PetrolHeadPetrolHead Posts: 3
    Newest version is a bootle neck for me to, revesed to older and its okay even tried this one without any luck ---->

  • BB8BB8 Posts: 3

    Thansk for the update but it does not solve my issue here. I believe my problem is more specific to the use of a company VPN in conjunction with Freedome. As I mentioned, I am aware that this is not supported and should not work but it had worked perfectly in the version of Freedome preceeding 1.15. I would still like that old installer if anyone can provide it. I have had to stop using Freedome on my work machines as a result of the recent changes and I'd like to get it back to how it was. I'm happy to test any new builds you have but I could use the old installer in the meantime. 




This discussion has been closed.